summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 31 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0830822011e2..1c42baa99786 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = texturepacker
- pkgdesc = Sprite sheet creator and image optimizer
- pkgver = 4.10.0
- pkgrel = 1
- url = https://www.codeandweb.com/texturepacker
- install = texturepacker.install
- arch = x86_64
- license = custom:texturepacker
- depends = shared-mime-info
- depends = hicolor-icon-theme
- depends = desktop-file-utils
- depends = grantlee-qt5
- depends = gcc-libs-multilib
- depends = qt5-svg
- depends = qt5-declarative
- depends = qt5-imageformats
- depends = qt5-quickcontrols
- source = https://www.codeandweb.com/download/texturepacker/4.10.0/TexturePacker-4.10.0-ubuntu64.deb
- sha256sums = 98e6c48a45765a49596dcca58e4f6edd70dbcb9b319337a1d77626162571d287
+pkgdesc = Sprite sheet creator and image optimizer
+pkgver = 7.1.0
+pkgrel = 1
+url = https://www.codeandweb.com/texturepacker
+install = texturepacker.install
+arch = x86_64
+license = custom:texturepacker
+depends = shared-mime-info
+depends = hicolor-icon-theme
+depends = desktop-file-utils
+depends = grantlee
+depends = gcc-libs-multilib
+depends = qt5-svg
+depends = qt5-declarative
+depends = qt5-imageformats
+depends = qt5-quickcontrols
+source = https://www.codeandweb.com/download/texturepacker/7.1.0/TexturePacker-7.1.0.deb
+sha256sums = f476e674c3d3a7aa9908453f94866fe076e3294944b4f56f6a5fb2d2d89839b7
pkgname = texturepacker
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f96dddd37e6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.deb
+texturepacker* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index c95ba1fa8d22..d8a96aaf5420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
+# Maintainer: konez2k@aur
+# Contributor: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
# Contributor: Etzos <supercodingmonkey @ gmail.com>
# Contributer: Gordin <9ordin @t gmail dot com>
# Contributor: Geequlim <geequlim@gmail.com>
# Contributor: Antti Juhani Oja <antti.oja@gmail.com>
pkgname=texturepacker
-pkgver=4.10.0
+pkgver=7.1.0
pkgrel=1
pkgdesc="Sprite sheet creator and image optimizer"
arch=('x86_64')
url="https://www.codeandweb.com/$pkgname"
license=("custom:$pkgname")
install="$pkgname.install"
-depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee-qt5'
- 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
- 'qt5-quickcontrols')
-source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/TexturePacker-${pkgver}-ubuntu64.deb")
-sha256sums=("98e6c48a45765a49596dcca58e4f6edd70dbcb9b319337a1d77626162571d287")
+depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee'
+ 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
+ 'qt5-quickcontrols')
+source=("https://www.codeandweb.com/download/$pkgname/${pkgver}/TexturePacker-${pkgver}.deb")
+sha256sums=("f476e674c3d3a7aa9908453f94866fe076e3294944b4f56f6a5fb2d2d89839b7")
build() {
- ar -x "TexturePacker-${pkgver}-ubuntu64.deb"
+ ar -x "TexturePacker-${pkgver}.deb"
}
package() {
@@ -31,19 +32,6 @@ package() {
# Enter $pkgdir.
cd ${pkgdir}/usr/lib/$pkgname/
- # IMPORTANT NOTE: It looks like codeandweb stopped compiling with the -fPIC
- # flag. We must keep the bloat for now.
-
- # Delete all the extra lib folders.
- #rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
- # QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
-
- # Delete the useless lib files.
- #rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
-
- # Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
- #rm -rf qt.conf
-
install -Dm644 "${pkgdir}/usr/share/$pkgname/documents/LicenseAgreement.txt" \
"${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"
}