summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD48
-rw-r--r--texturepacker.install15
3 files changed, 47 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d752f917cfd..54f1e043582d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Sep 3 20:04:04 UTC 2016
pkgbase = texturepacker
pkgdesc = Sprite sheet creator and image optimizer
- pkgver = 3.7.1
+ pkgver = 4.2.3
pkgrel = 1
url = http://www.texturepacker.com
install = texturepacker.install
@@ -10,8 +12,8 @@ pkgbase = texturepacker
depends = hicolor-icon-theme
depends = desktop-file-utils
depends = shared-mime-info
- source = http://www.codeandweb.com/download/texturepacker/3.7.1/TexturePacker-3.7.1-ubuntu64.deb
- md5sums = 9f75c5786602dc3942fdce2e3fe7a763
+ source = http://www.codeandweb.com/download/texturepacker/4.2.3/TexturePacker-4.2.3-ubuntu64.deb
+ md5sums = SKIP
pkgname = texturepacker
diff --git a/PKGBUILD b/PKGBUILD
index a4657c5dd765..2557045dc303 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,45 @@
-# Maintainer: Etzos <supercodingmonkey @ gmail.com>
+# Maintainer: Wilson E. Alvarez <wilson.e.alvarez1@gmail.com>
+# Contributor: Etzos <supercodingmonkey @ gmail.com>
# Contributer: Gordin <9ordin @t gmail dot com>
+# Contributor: Geequlim <geequlim@gmail.com>
pkgname=texturepacker
-pkgver=3.7.1
+pkgver=4.2.3
pkgrel=1
pkgdesc="Sprite sheet creator and image optimizer"
arch=('x86_64')
-url="http://www.texturepacker.com"
-license=('custom:texturepacker')
-install='texturepacker.install'
-depends=('glib2' 'hicolor-icon-theme' 'desktop-file-utils' 'shared-mime-info')
-source=("http://www.codeandweb.com/download/texturepacker/${pkgver}/TexturePacker-${pkgver}-ubuntu64.deb")
-md5sums=('9f75c5786602dc3942fdce2e3fe7a763')
+url="https://www.codeandweb.com/$pkgname"
+license=("custom:$pkgname")
+install="$pkgname.install"
+depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'grantlee-qt5'
+ 'gcc-libs-multilib' 'qt5-svg' 'qt5-declarative' 'qt5-imageformats'
+ 'qt5-quickcontrols')
+source=("http://www.codeandweb.com/download/$pkgname/${pkgver}/TexturePacker-${pkgver}-ubuntu64.deb")
+md5sums=('44e3f650fef2e39c204e3787f603f3d1')
build() {
- ar -xv "TexturePacker-${pkgver}-ubuntu64.deb"
- tar -xvf data.tar.xz
+ ar -x "TexturePacker-${pkgver}-ubuntu64.deb"
}
package() {
- # Program
- mv ${srcdir}/usr ${pkgdir}
- # License
- install -Dm644 "${pkgdir}/usr/share/texturepacker/documents/LicenseAgreement.html" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.html"
+ cd ${srcdir}/
+
+ # Extract to the $pkgdir.
+ tar xJf data.tar.xz -C "${pkgdir}/"
+
+ # Enter $pkgdir.
+ cd ${pkgdir}/usr/lib/texturepacker/
+
+ # Delete all the extra lib folders.
+ rm -rf generic/ grantlee/ iconengines/ imageformats/ platforminputcontexts/ platforms/ \
+ QtGraphicalEffects/ QtQml/ QtQuick/ QtQuick.2/ xcbglintegrations/
+
+ # Delete the useless lib files.
+ rm -rf libGrantlee* libicudata* libicui18n* libicuuc* libQt5*
+
+ # Get rid of the Qt configuration that messes up LD_LIBRARY_PATH.
+ rm -rf qt.conf
+
+ install -Dm644 "${pkgdir}/usr/share/texturepacker/documents/LicenseAgreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LicenseAgreement.txt"
}
diff --git a/texturepacker.install b/texturepacker.install
index 007e4b662a18..b791ea51fe4b 100644
--- a/texturepacker.install
+++ b/texturepacker.install
@@ -1,9 +1,13 @@
post_install() {
- update-mime-database usr/share/mime
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- echo "You must accept the terms of the EULA before using TexturePacker!"
- echo "Can be found in /usr/share/licenses/texturepacker/LicenseAgreement.html"
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ printf "%s\n" \
+ "You are required to accept the terms of the TexturePacker EULA before using the" \
+ "software. The software will prompt you to accept these terms on the first" \
+ "startup." \
+ "You can read the terms of the license without starting TexturePacker at:" \
+ " /usr/share/licenses/texturepacker/LicenseAgreement.txt"
}
post_upgrade() {
@@ -15,4 +19,3 @@ post_remove() {
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
-