summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2934a71c2761
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = tgcd
+ pkgdesc = tgcd, tcp gender change daemon (reverse tunnel)
+ pkgver = v1.1.1.0.g4222d3e
+ pkgrel = 1
+ url = http://tgcd.sourceforge.net/#lbAD
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ options = !buildflags
+ source = git+https://github.com/archimedepitagorico/tgcd.git#tag=v1.1.1
+ sha1sums = SKIP
+
+pkgname = tgcd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a45cf93ab2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Archimede Pitagorico <archimede.pitagorico@mail.com>
+
+pkgname=tgcd
+pkgver=v1.1.1.0.g4222d3e
+pkgrel=1
+pkgdesc="tgcd, tcp gender change daemon (reverse tunnel)"
+arch=('x86_64')
+url='http://tgcd.sourceforge.net/#lbAD'
+license=('GNU-GPL2')
+source=('git+https://github.com/archimedepitagorico/tgcd.git#tag=v1.1.1'
+ )
+#install=$pkgname.install
+
+makedepends=('git'
+ )
+sha1sums=('SKIP'
+ )
+options=('!buildflags'
+ )
+
+pkgver() {
+ cd tgcd
+ echo "$(git describe --long --tags | tr - . | tr _ .)"
+}
+
+prepare() {
+ cd tgcd
+ ./configure
+}
+
+build() {
+ cd tgcd
+ make
+}
+
+package() {
+ cd tgcd
+ make DESTDIR=${pkgdir} install
+ mv ${pkgdir}/usr/local/* ${pkgdir}/usr
+ rmdir ${pkgdir}/usr/local
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}