summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
-rw-r--r--tgl-ttf.install15
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a06b7b6d44ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = tgl-ttf
+ pkgdesc = TGL DIN ISO custom font
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.1001fonts.com/tgl-font.html
+ install = tgl-ttf.install
+ arch = any
+ license = custom:SIL Open Font License v1.1
+ source = http://dl.1001fonts.com/tgl.zip
+ md5sums = 84e185e597f39e0a6629179fa2b0da5e
+
+pkgname = tgl-ttf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50fa98148253
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: John Beard <john dot j dot beard at gmail dot com>
+# Author: Peter Wiegel <wiegel at peter-wiegel dot de>
+
+pkgname=tgl-ttf
+pkgver=1.0
+pkgrel=1
+url="http://www.1001fonts.com/tgl-font.html"
+license=('custom:SIL Open Font License v1.1')
+pkgdesc='TGL DIN ISO custom font'
+arch=('any')
+source=("http://dl.1001fonts.com/tgl.zip")
+depends=('fontconfig' 'xorg-font-utils')
+install=$pkgname.install
+md5sums=('84e185e597f39e0a6629179fa2b0da5e')
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+ install -dm755 "${pkgdir}"/usr/share/licenses/${pkgname}/
+ install -Dm644 "${srcdir}"/TGL\ *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+ install -Dm644 "Open Font License.txt" "${pkgdir}"/usr/share/licenses/${pkgname}/
+}
+
diff --git a/tgl-ttf.install b/tgl-ttf.install
new file mode 100644
index 000000000000..d11a6d7f088b
--- /dev/null
+++ b/tgl-ttf.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache >/dev/null -f
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}