summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--thc-ssl-dos.install8
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16161b84c4da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Dec 14 04:46:42 UTC 2015
+pkgbase = thc-ssl-dos
+ pkgdesc = THC-SSL-DOS is a tool to verify the performance of SSL by flooding connections
+ pkgver = 1.4
+ pkgrel = 2
+ url = http://www.thc.org/thc-ssl-dos/
+ install = thc-ssl-dos.install
+ arch = i686
+ arch = x86_64
+ license = custom: unknown
+ depends = openssl
+ depends = glibc
+ depends = zlib
+ source = http://www.thc.org/thc-ssl-dos/thc-ssl-dos-1.4.tar.gz
+ md5sums = 0d75fc5d6aaf22130c57436fea3ca339
+
+pkgname = thc-ssl-dos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e99533bcc751
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Original Maintainer: Testuser_01 <arch@nico-siebler.de>
+# really shit PKGBUILD fixed by: GI_Jack <iamjacksemail@hackermail.com>
+
+# I have no idea why there were so many explicit warnings about the dangers of
+# improperly using netsec tools in the original uncleaned PKGBUILD from AUR3.
+# needless to say they were removed.
+
+pkgname=thc-ssl-dos
+pkgver=1.4
+pkgrel=2
+pkgdesc="THC-SSL-DOS is a tool to verify the performance of SSL by flooding connections"
+url="http://www.thc.org/${pkgname}/"
+arch=('i686' 'x86_64')
+install="${pkgname}.install"
+license=('custom: unknown')
+depends=('openssl' 'glibc' 'zlib')
+source=("http://www.thc.org/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('0d75fc5d6aaf22130c57436fea3ca339')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || return 1
+ ./configure --prefix=/usr || return 1
+ make all || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || return 1
+ mkdir -p "${pkgdir}/usr/bin/" || return 1
+ install -m755 -D "src/${pkgname}" "${pkgdir}/usr/bin/" || return 1
+}
diff --git a/thc-ssl-dos.install b/thc-ssl-dos.install
new file mode 100644
index 000000000000..826b67819dfb
--- /dev/null
+++ b/thc-ssl-dos.install
@@ -0,0 +1,8 @@
+function post_install() {
+ printf "\033[1;34;40m => \033[1;37;40mUse this for help:\033[0;0m\n"
+ printf " \033[1;34;40m -> \033[1;37;40mthc-ssl-dos -h\033[0;0m\n"
+}
+
+function post_upgrade() {
+ post_install
+}