summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--package.json90
3 files changed, 54 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1fe804e25eb..0506dc256c2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = theia-electron
pkgdesc = Cloud & Desktop IDE Platform
- pkgver = 1.3.0
- pkgrel = 2
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://www.theia-ide.org/
arch = any
license = EPL2
@@ -22,10 +22,10 @@ pkgbase = theia-electron
source = package.json
source = .yarnclean
source = theia-electron.desktop
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.3.0/logo/theia.svg
- source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.3.0/LICENSE
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.4.0/logo/theia.svg
+ source = https://raw.githubusercontent.com/eclipse-theia/theia/v1.4.0/LICENSE
md5sums = 5a26cc7b1b461bec8533266dbe64c87e
- md5sums = bba497da728fc3794e8382a095d07469
+ md5sums = 4afa80c7dbb0391e94b1bdefd28636ee
md5sums = 54b30057095cf131ec7296b0d0bd2046
md5sums = b316dead79fa33f45c8d689a1c940dab
md5sums = 1dde0e422484895d3509f4ee9bb8d980
diff --git a/PKGBUILD b/PKGBUILD
index 952f1317c497..22d3f279e521 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Bence HornĂ¡k <bence.hornak@gmail.com>
pkgname=theia-electron
-pkgver=1.3.0
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
arch=('any')
url='https://www.theia-ide.org/'
pkgdesc="Cloud & Desktop IDE Platform"
@@ -21,7 +21,7 @@ source=(
"https://raw.githubusercontent.com/eclipse-theia/theia/v$pkgver/LICENSE"
)
md5sums=('5a26cc7b1b461bec8533266dbe64c87e'
- 'bba497da728fc3794e8382a095d07469'
+ '4afa80c7dbb0391e94b1bdefd28636ee'
'54b30057095cf131ec7296b0d0bd2046'
'b316dead79fa33f45c8d689a1c940dab'
'1dde0e422484895d3509f4ee9bb8d980'
diff --git a/package.json b/package.json
index d09853548055..5413fd829be3 100644
--- a/package.json
+++ b/package.json
@@ -1,6 +1,6 @@
{
"private": true,
- "version": "1.3.0",
+ "version": "1.4.0",
"main": "src-gen/frontend/electron-main.js",
"license": "EPL-2.0 OR GPL-2.0 WITH Classpath-exception-2.0",
"theia": {
@@ -31,13 +31,14 @@
"vscode-builtin-gulp": "https://open-vsx.org/api/vscode/gulp/1.44.2/file/vscode.gulp-1.44.2.vsix",
"vscode-builtin-handlebars": "https://open-vsx.org/api/vscode/handlebars/1.44.2/file/vscode.handlebars-1.44.2.vsix",
"vscode-builtin-hlsl": "https://open-vsx.org/api/vscode/hlsl/1.44.2/file/vscode.hlsl-1.44.2.vsix",
- "vscode-builtin-html": "https://open-vsx.org/api/vscode/html/1.44.2/file/vscode.html-1.44.2.vsix",
- "vscode-builtin-html-language-features": "https://open-vsx.org/api/vscode/html-language-features/1.45.1/file/vscode.html-language-features-1.45.1.vsix",
+ "vscode-builtin-html": "https://open-vsx.org/api/vscode/html/1.48.0-next.4a1bcdafe9/file/vscode.html-1.48.0-next.4a1bcdafe9.vsix",
+ "vscode-builtin-html-language-features": "https://open-vsx.org/api/vscode/html-language-features/1.48.0-next.4a1bcdafe9/file/vscode.html-language-features-1.48.0-next.4a1bcdafe9.vsix",
"vscode-builtin-ini": "https://open-vsx.org/api/vscode/ini/1.44.2/file/vscode.ini-1.44.2.vsix",
"vscode-builtin-jake": "https://open-vsx.org/api/vscode/jake/1.44.2/file/vscode.jake-1.44.2.vsix",
"vscode-builtin-java": "https://open-vsx.org/api/vscode/java/1.44.2/file/vscode.java-1.44.2.vsix",
"vscode-builtin-javascript": "https://open-vsx.org/api/vscode/javascript/1.44.2/file/vscode.javascript-1.44.2.vsix",
- "vscode-builtin-json": "https://open-vsx.org/api/vscode/json/1.44.2/file/vscode.json-1.44.2.vsix",
+ "vscode-builtin-json": "https://open-vsx.org/api/vscode/json/1.46.1/file/vscode.json-1.46.1.vsix",
+ "vscode-builtin-json-language-features": "https://open-vsx.org/api/vscode/json-language-features/1.46.1/file/vscode.json-language-features-1.46.1.vsix",
"vscode-builtin-less": "https://open-vsx.org/api/vscode/less/1.44.2/file/vscode.less-1.44.2.vsix",
"vscode-builtin-log": "https://open-vsx.org/api/vscode/log/1.44.2/file/vscode.log-1.44.2.vsix",
"vscode-builtin-lua": "https://open-vsx.org/api/vscode/lua/1.44.2/file/vscode.lua-1.44.2.vsix",
@@ -82,50 +83,51 @@
"vscode-references-view": "https://open-vsx.org/api/ms-vscode/references-view/0.0.47/file/ms-vscode.references-view-0.0.47.vsix"
},
"dependencies": {
- "@theia/callhierarchy": "1.3.0",
- "@theia/console": "1.3.0",
- "@theia/core": "1.3.0",
- "@theia/debug": "1.3.0",
- "@theia/editor": "1.3.0",
- "@theia/editor-preview": "1.3.0",
- "@theia/electron": "1.3.0",
- "@theia/file-search": "1.3.0",
- "@theia/filesystem": "1.3.0",
- "@theia/getting-started": "1.3.0",
- "@theia/git": "1.3.0",
- "@theia/json": "1.3.0",
- "@theia/keymaps": "1.3.0",
- "@theia/languages": "1.3.0",
- "@theia/markers": "1.3.0",
- "@theia/messages": "1.3.0",
- "@theia/metrics": "1.3.0",
- "@theia/mini-browser": "1.3.0",
- "@theia/monaco": "1.3.0",
- "@theia/navigator": "1.3.0",
- "@theia/outline-view": "1.3.0",
- "@theia/output": "1.3.0",
- "@theia/plugin-dev": "1.3.0",
- "@theia/plugin-ext": "1.3.0",
- "@theia/plugin-ext-vscode": "1.3.0",
- "@theia/preferences": "1.3.0",
- "@theia/preview": "1.3.0",
- "@theia/process": "1.3.0",
- "@theia/scm": "1.3.0",
- "@theia/scm-extra": "1.3.0",
- "@theia/search-in-workspace": "1.3.0",
- "@theia/task": "1.3.0",
- "@theia/terminal": "1.3.0",
- "@theia/typehierarchy": "1.3.0",
- "@theia/userstorage": "1.3.0",
- "@theia/variable-resolver": "1.3.0",
- "@theia/vsx-registry": "1.3.0",
- "@theia/workspace": "1.3.0"
+ "@theia/callhierarchy": "1.4.0",
+ "@theia/console": "1.4.0",
+ "@theia/core": "1.4.0",
+ "@theia/debug": "1.4.0",
+ "@theia/editor": "1.4.0",
+ "@theia/editor-preview": "1.4.0",
+ "@theia/electron": "1.4.0",
+ "@theia/file-search": "1.4.0",
+ "@theia/filesystem": "1.4.0",
+ "@theia/getting-started": "1.4.0",
+ "@theia/git": "1.4.0",
+ "@theia/keymaps": "1.4.0",
+ "@theia/languages": "1.4.0",
+ "@theia/markers": "1.4.0",
+ "@theia/messages": "1.4.0",
+ "@theia/metrics": "1.4.0",
+ "@theia/mini-browser": "1.4.0",
+ "@theia/monaco": "1.4.0",
+ "@theia/navigator": "1.4.0",
+ "@theia/outline-view": "1.4.0",
+ "@theia/output": "1.4.0",
+ "@theia/plugin": "1.4.0",
+ "@theia/plugin-dev": "1.4.0",
+ "@theia/plugin-ext": "1.4.0",
+ "@theia/plugin-ext-vscode": "1.4.0",
+ "@theia/plugin-metrics": "1.4.0",
+ "@theia/preferences": "1.4.0",
+ "@theia/preview": "1.4.0",
+ "@theia/process": "1.4.0",
+ "@theia/scm": "1.4.0",
+ "@theia/scm-extra": "1.4.0",
+ "@theia/search-in-workspace": "1.4.0",
+ "@theia/task": "1.4.0",
+ "@theia/terminal": "1.4.0",
+ "@theia/typehierarchy": "1.4.0",
+ "@theia/userstorage": "1.4.0",
+ "@theia/variable-resolver": "1.4.0",
+ "@theia/vsx-registry": "1.4.0",
+ "@theia/workspace": "1.4.0"
},
"devDependencies": {
- "@theia/cli": "1.3.0"
+ "@theia/cli": "1.4.0"
},
"scripts": {
"build": "electron-rebuild && theia download:plugins && theia build --mode production",
"start": "theia start"
}
-} \ No newline at end of file
+}