aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 354d9472062e..8390e4218675 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thelounge
pkgdesc = Modern self-hosted web IRC client
pkgver = 4.4.3
- pkgrel = 2
+ pkgrel = 3
url = https://thelounge.chat/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b31c38252f58..2c5401b222b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=thelounge
pkgver=4.4.3
pkgsuffix="" #-rc.1
-pkgrel=2
+pkgrel=3
pkgdesc='Modern self-hosted web IRC client'
url='https://thelounge.chat/'
arch=('any')
@@ -48,6 +48,12 @@ build() {
file:"$srcdir/$pkgname-${pkgver}${pkgsuffix}.tgz"
# fetch sqlite3 binary blob
+
+ # node-gyp or node have a bug that prevents building with "text file busy" if the kernel is too fast
+ # so we have to disable IO_URING support. This is cleary a hack and needs to be removed as soon as possible
+ # https://github.com/nodejs/node/issues/48444 is the necro bumped thread originally in docker
+ export UV_USE_IO_URING=0
+
cd node_modules/sqlite3 || exit 1
yarn run install
}