summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fdf488c41ca..46dab2b8b1dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thelounge-beta
pkgdesc = Modern self-hosted web IRC client (Latest release/pre-release)
- pkgver = 4.4.2rc.1
+ pkgver = 4.4.3
pkgrel = 1
url = https://thelounge.chat/
arch = any
@@ -11,19 +11,19 @@ pkgbase = thelounge-beta
depends = nodejs
provides = thelounge
conflicts = thelounge
- noextract = thelounge-4.4.2-rc.1.tgz
+ noextract = thelounge-4.4.3.tgz
options = !lto
backup = etc/thelounge/config.js
- source = https://registry.npmjs.org/thelounge/-/thelounge-4.4.2-rc.1.tgz
- source = https://raw.githubusercontent.com/thelounge/thelounge/v4.4.2-rc.1/yarn.lock
- source = https://raw.githubusercontent.com/thelounge/thelounge/v4.4.2-rc.1/package.json
+ source = https://registry.npmjs.org/thelounge/-/thelounge-4.4.3.tgz
+ source = https://raw.githubusercontent.com/thelounge/thelounge/v4.4.3/yarn.lock
+ source = https://raw.githubusercontent.com/thelounge/thelounge/v4.4.3/package.json
source = system.service
source = user.service
source = sysusers.d
source = tmpfiles.d
- sha256sums = 8d5baaa27721c13b7c9012e0ae0c1944cbcbbf0810a7014501ea030550ecde33
+ sha256sums = 685d753ad080c35ac7c4cf2eef6437df8de47a3d352b10f06d56acc9a08f4f18
sha256sums = 0bcb88814337e6dd1352dd382a14e6c277f71410767277db34c97b998e1cd0b9
- sha256sums = 8db0269b05dc4ea8faec9491967ff20587e2eb4d6b1bce7ef206d6a118d1b899
+ sha256sums = e0cca2931e46842039fcbc78efbecae4b9893608d18959f616aa7ea559311441
sha256sums = c92210f6ac8f01c1cd01b6b26793094cd2feea583ed21fab3564d6bcafdc7a20
sha256sums = c609f3309f54bd6285e99ff29ca2464828bec7bbbca67243ee688bd2d605dbf0
sha256sums = 30fab63b8a4ffcfdda4c5b8d7c66822a323c4f1de6ca62b77fe9500f4befc0a5
diff --git a/PKGBUILD b/PKGBUILD
index 1d549eed45b7..8068133bab45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Maxime Poulin <maxpoulin64@gmail.com>
_pkgname=thelounge
pkgname=thelounge-beta
-_pkgver=4.4.2-rc.1
+_pkgver=4.4.3
pkgver=${_pkgver/-/}
pkgrel=1
pkgdesc='Modern self-hosted web IRC client (Latest release/pre-release)'
@@ -26,9 +26,9 @@ source=(
'tmpfiles.d'
)
noextract=("$_pkgname-$_pkgver.tgz")
-sha256sums=('8d5baaa27721c13b7c9012e0ae0c1944cbcbbf0810a7014501ea030550ecde33'
+sha256sums=('685d753ad080c35ac7c4cf2eef6437df8de47a3d352b10f06d56acc9a08f4f18'
'0bcb88814337e6dd1352dd382a14e6c277f71410767277db34c97b998e1cd0b9'
- '8db0269b05dc4ea8faec9491967ff20587e2eb4d6b1bce7ef206d6a118d1b899'
+ 'e0cca2931e46842039fcbc78efbecae4b9893608d18959f616aa7ea559311441'
'c92210f6ac8f01c1cd01b6b26793094cd2feea583ed21fab3564d6bcafdc7a20'
'c609f3309f54bd6285e99ff29ca2464828bec7bbbca67243ee688bd2d605dbf0'
'30fab63b8a4ffcfdda4c5b8d7c66822a323c4f1de6ca62b77fe9500f4befc0a5'
@@ -41,7 +41,7 @@ prepare() {
build() {
mkdir -p _build
cp package.json yarn.lock _build
- cd _build
+ cd _build || exit 1
# Install the package itself
# we on purpose don't use yarn global add, because --ignore-scripts
@@ -52,8 +52,8 @@ build() {
file:"$srcdir/$_pkgname-${_pkgver}.tgz"
# fetch sqlite3 binary blob
- cd node_modules/sqlite3
- ./node_modules/.bin/prebuild-install -r napi || node-gyp rebuild
+ cd node_modules/sqlite3 || exit 1
+ yarn run install
}
package() {