summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD62
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1ec8b26af4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = themix-icons-suru-plus-git
+ pkgdesc = Suru++ icons plugin for Themix GUI designer
+ pkgver = v30.0.r2.g9bd895f32
+ pkgrel = 1
+ url = https://github.com/gusbemacbe/suru-plus/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = python
+ depends = sed
+ depends = findutils
+ optdepends = themix-gui: GUI
+ optdepends = yaru-icon-theme: fallback icons
+ optdepends = gnome-icon-theme: fallback icons
+ optdepends = gnome-icon-theme-symbolic: fallback icons
+ provides = themix-icons-suru-plus
+ conflicts = themix-icons-suru-plus
+ options = !strip
+ source = git+https://github.com/themix-project/oomox.git#branch=master
+ source = suru-plus::git+https://github.com/gusbemacbe/suru-plus.git#branch=master
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = themix-icons-suru-plus-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..10bb602e5b61
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+
+oomox/
+suru-plus/
+themix-icons-suru-plus-git-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c46579df61d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
+# Upstream URL: https://github.com/gusbemacbe/suru-plus/
+
+_pkgname=themix-icons-suru-plus
+_reponame=suru-plus
+pkgname="${_pkgname}-git"
+pkgver=v30.0.r2.g9bd895f32
+pkgrel=1
+pkgdesc="Suru++ icons plugin for Themix GUI designer"
+arch=('x86_64' 'i686')
+url="https://github.com/gusbemacbe/suru-plus/"
+license=('GPL3')
+source=(
+ "git+https://github.com/themix-project/oomox.git#branch=master"
+ "${_reponame}::git+https://github.com/gusbemacbe/suru-plus.git#branch=master"
+)
+md5sums=('SKIP'
+ 'SKIP')
+depends=(
+ 'sed'
+ 'findutils'
+)
+makedepends=(
+ 'git'
+ 'python'
+)
+optdepends=(
+ 'themix-gui: GUI'
+ 'yaru-icon-theme: fallback icons'
+ 'gnome-icon-theme: fallback icons'
+ 'gnome-icon-theme-symbolic: fallback icons'
+)
+options=(
+ '!strip'
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "${srcdir}/${_reponame}"
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _oomox_dir=/opt/oomox
+ _plugin_name=icons_suruplus
+ _plugin_subpath="/${_reponame}"
+
+ pkg_tmp_dir="${pkgdir}/_tmp"
+ rm -fr "$pkg_tmp_dir"
+ cp -r "${srcdir}/oomox" "$pkg_tmp_dir"
+ rm -rf "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+ cp -r "${srcdir}/${_reponame}" "${pkg_tmp_dir}/plugins/${_plugin_name}${_plugin_subpath}"
+
+ cd "$pkg_tmp_dir"
+ make DESTDIR="${pkgdir}" APPDIR="${_oomox_dir}" PREFIX="/usr" "install_${_plugin_name}"
+ rm -fr "$pkg_tmp_dir"
+
+ python -O -m compileall "${pkgdir}${_oomox_dir}/plugins/${_plugin_name}" -d "${_oomox_dir}/plugins/${_plugin_name}"
+}
+
+# vim: ft=PKGBUILD