summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b72754af4d6e..b2323c52945b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,13 @@ pkgbase = themix-import-images-git
arch = i686
license = GPL3
makedepends = git
- depends = gtk3
- depends = python-gobject
+ depends = themix-gui
+ depends = python-pillow
optdepends = colorz: additional image analyzer
optdepends = python-colorthief: additional image analyzer
optdepends = python-haishoku: additional image analyzer
- provides = themix-gui
- conflicts = themix-gui
+ provides = themix-import-images
+ conflicts = themix-import-images
source = git+https://github.com/themix-project/oomox.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d1eddd17b3c0..559dc9063d8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
# Upstream URL: https://github.com/themix-project/oomox
-pkgname=themix-import-images-git
+_pkgname=themix-import-images
+pkgname="${_pkgname}-git"
pkgver=1.12.6.r14.ge495c2c3
pkgrel=1
pkgdesc="Import plugin for Themix GUI designer to get color palettes from the images"
@@ -13,8 +14,8 @@ source=(
)
md5sums=('SKIP')
depends=(
- 'gtk3'
- 'python-gobject'
+ 'themix-gui'
+ 'python-pillow'
)
makedepends=(
'git'
@@ -24,8 +25,8 @@ optdepends=(
'python-colorthief: additional image analyzer'
'python-haishoku: additional image analyzer'
)
-provides=('themix-gui')
-conflicts=('themix-gui')
+provides=($_pkgname)
+conflicts=($_pkgname)
pkgver() {
cd "${srcdir}/oomox"