summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--CHANGELOG24
-rwxr-xr-xPKGBUILD106
-rw-r--r--loch_vtk7.patch26
-rw-r--r--make_install.patch43
5 files changed, 116 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 611c0b5b961f..3e95fe91685c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,36 @@
-# Generated by mksrcinfo v8
-# Fri Apr 21 09:09:58 UTC 2017
pkgbase = therion
- pkgdesc = A cave surveying software
- pkgver = 5.4.1
+ pkgdesc = Cave surveying: processes survey data and generates maps or 3D models of caves
+ pkgver = 6.2.1
pkgrel = 1
url = http://therion.speleo.sk
+ changelog = CHANGELOG
arch = x86_64
arch = i686
license = GPL2
- depends = tk
+ makedepends = catch2
+ makedepends = cmake
+ makedepends = perl
depends = bwidget
- depends = texlive-core
- depends = imagemagick
- depends = wxgtk
+ depends = fmt
+ depends = freetype2
depends = glu
+ depends = imagemagick
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = python
+ depends = shapelib
+ depends = texlive-core
+ depends = texlive-metapost
+ depends = tk
+ depends = tkimg
depends = vtk
- depends = webkitgtk2
- optdepends = libjpeg-turbo
- optdepends = libpng
- optdepends = zlib
- source = http://github.com/therion/therion/archive/v5.4.1.tar.gz
- source = loch_vtk7.patch
- source = make_install.patch
+ depends = wxwidgets-gtk3
+ depends = zlib
+ backup = etc/therion.ini
+ backup = etc/xtherion.ini
+ source = http://github.com/therion/therion/archive/v6.2.1.tar.gz
source = therion_ini.patch
- sha256sums = 6e4b88d1803bdf252cf7d4632afcd9c4005e387245e9ac95774e6cc894ae4ccd
- sha256sums = 81cd6c75a74897831edd4116bb97c71090023abbb14725b96d2a219f67cb5613
- sha256sums = bf3fda048fb1a4f4c49f0daf7faa7e40c630748b33ed27c47bcfabba4014571c
+ sha256sums = 70fbb82091b3e8dbb4451604438588bc23c14af8398b1d32676eae019c5f3131
sha256sums = 0639b0c4c9660af33675bf948ca4678d441167f77f7818cc015b7738a53fb8f3
pkgname = therion
-
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..a14063493ab4
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,24 @@
+# 5.4.4-3 - 2019-10-12 - Rodrigo Severo
+- updating maintainer
+- including the following depends: freetype2, python and tkimg
+- upgrading the following optdepends to depends: libjpeg-turbo, libpng, zlib
+- including makedepends: perl
+- created this CHANGELOG
+- updated package description
+
+# 5.4.4-4 - 2019-10-12 - Rodrigo Severo
+- removed unnecessary quoting in PKGBUILD
+
+# 5.4.4-5 - 2019-10-12 - Rodrigo Severo
+- finally fixing quoting in PKGBUILD
+
+# 5.5.3-1 - 2020-10-19 - Thomas Holder
+- enable parallel execution
+- add ini files to backup
+- remove depends: webkitgtk2
+
+# 5.5.6-2 - 2021-01-17 - Thomas Holder
+- use wxgtk3
+
+# 6.0.2-1 - 2021-09-23 - Thomas Holder
+- use cmake
diff --git a/PKGBUILD b/PKGBUILD
index 166fddb16723..d4320c5b7235 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,87 @@
-# Maintainer: detrito <detrito@inventati.org>
-# Contributor: Thomas Holder <thomas@thomas-holder.de>
-# Contributor: detrito <detrito@inventati.org>
-
-pkgname=therion
-pkgver=5.4.1
-pkgrel=2
-pkgdesc="A cave surveying software"
+# Maintainer: Thomas Holder <thomas at thomas-holder dot de>
+# Contributor: detrito <detrito at inventati dot org>
+# Contributor: Rodrigo Severo <rsev at protonmail dot com>
+
+pkgname='therion'
+pkgver='6.2.1'
+pkgrel='1'
+pkgdesc="Cave surveying: processes survey data and generates maps or 3D models of caves"
arch=('x86_64' 'i686')
url="http://therion.speleo.sk"
license=('GPL2')
+changelog='CHANGELOG'
-# avoid parallel-execution errors
-MAKEFLAGS="-j1"
-
-depends=('tk' 'bwidget' 'texlive-core' 'imagemagick' 'wxgtk' 'glu' 'vtk'
- 'webkitgtk2')
+depends=(
+ 'bwidget'
+ 'fmt'
+ 'freetype2'
+ 'glu'
+ 'imagemagick'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'python'
+ 'shapelib'
+ 'texlive-core'
+ 'texlive-metapost'
+ 'tk'
+ 'tkimg'
+ 'vtk'
+ 'wxwidgets-gtk3'
+ 'zlib'
+)
-optdepends=('libjpeg-turbo' 'libpng' 'zlib')
+makedepends=(
+ 'catch2'
+ 'cmake'
+ 'perl'
+)
-source=("http://github.com/therion/therion/archive/v${pkgver}.tar.gz"
- "loch_vtk7.patch"
- "make_install.patch"
- "therion_ini.patch")
+source=(
+ "http://github.com/therion/therion/archive/v${pkgver}.tar.gz"
+ 'therion_ini.patch'
+)
-sha256sums=('6e4b88d1803bdf252cf7d4632afcd9c4005e387245e9ac95774e6cc894ae4ccd'
- '81cd6c75a74897831edd4116bb97c71090023abbb14725b96d2a219f67cb5613'
- 'bf3fda048fb1a4f4c49f0daf7faa7e40c630748b33ed27c47bcfabba4014571c'
+sha256sums=(
+ '70fbb82091b3e8dbb4451604438588bc23c14af8398b1d32676eae019c5f3131'
'0639b0c4c9660af33675bf948ca4678d441167f77f7818cc015b7738a53fb8f3'
- )
+)
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+backup=(
+ etc/therion.ini
+ etc/xtherion.ini
+)
- # patch to compile loch with VTK 7.1
- patch -p0 -i ${srcdir}/loch_vtk7.patch
+_builddir="build"
+_sourcedir="${pkgname}-${pkgver}"
- # patch to install in $pkgdir
- patch -p0 -i ${srcdir}/make_install.patch
+prepare() {
+ cd "${pkgname}-${pkgver}"
# patch to get UTF8 and available fonts
patch -p0 -i ${srcdir}/therion_ini.patch
-
- # path to fix loch compilation
- sed -i.bak 's/-DLXLINUX//' loch/Makefile
- sed -i.bak 's/^POBJECTS =.*/POBJECTS =/' loch/Makefile
- sed -i.bak 's/freetype-config --cflags/pkg-config --cflags freetype2/' loch/Makefile
-
- make
}
+build() {
+ cmake \
+ -B "${_builddir}" \
+ -S "${_sourcedir}" \
+ -DUSE_BUNDLED_FMT=OFF \
+ -DUSE_BUNDLED_CATCH2=OFF \
+ -DUSE_BUNDLED_SHAPELIB=OFF \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+
+ make -C "${_builddir}"
+}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ make -C "${_builddir}" DESTDIR="${pkgdir}" install/strip
+
+ mkdir -p "${pkgdir}/etc"
+
+ cp \
+ "${_sourcedir}/therion.ini" \
+ "${_sourcedir}/xtherion/xtherion.ini" \
+ "${pkgdir}/etc"
}
+
+
diff --git a/loch_vtk7.patch b/loch_vtk7.patch
deleted file mode 100644
index 3f13b7e8055b..000000000000
--- a/loch_vtk7.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- loch/Makefile_raw 2017-04-03 22:32:08.000000000 +0200
-+++ loch/Makefile 2017-04-10 18:52:01.320200225 +0200
-@@ -19,10 +19,10 @@
- CROSS =
- EXT =
-
--VTKVERSION = $(shell tclsh ./getvtkver.tcl version)
--VTKPATH = $(shell tclsh ./getvtkver.tcl incpath)
--VTKLIBPATH = $(shell tclsh ./getvtkver.tcl libpath)
--VTKV6 = $(shell tclsh ./getvtkver.tcl version6)
-+VTKVERSION = 7.1
-+VTKPATH = "/usr/include/vtk/"
-+VTKLIBPATH = "/usr/lib"
-+VTKV6 = 1
- ifeq ($(VTKV6),1)
- VTKLIBS = -lvtkCommonExecutionModel-$(VTKVERSION) -lvtkCommonDataModel-$(VTKVERSION) -lvtkCommonCore-$(VTKVERSION) -lvtkFiltersCore-$(VTKVERSION) -lvtkFiltersHybrid-$(VTKVERSION) -lvtkIOLegacy-$(VTKVERSION) -lfreetype -lpng -ljpeg
- else
-@@ -56,7 +56,7 @@
- CC = gcc
- POBJECTS = lxR2P.o
- ifeq ($(VTKV6),1)
--VTKLIBS = -lvtkCommonExecutionModel-$(VTKVERSION) -lvtkCommonDataModel-$(VTKVERSION) -lvtkCommonCore-$(VTKVERSION) -lvtkFiltersCore-$(VTKVERSION) -lvtkFiltersHybrid-$(VTKVERSION) -lvtkIOLegacy-$(VTKVERSION) -lfreetype -lpng -ljpeg
-+VTKLIBS = -lvtkCommonExecutionModel -lvtkCommonDataModel -lvtkCommonCore -lvtkFiltersCore -lvtkFiltersHybrid -lvtkIOLegacy -lfreetype -lpng -ljpeg
- else
- VTKLIBS = -lvtkHybrid -lvtkImaging -lvtkIO -lvtkGraphics -lvtkFiltering -lvtkCommon -lfreetype
- endif
diff --git a/make_install.patch b/make_install.patch
deleted file mode 100644
index b79ceb956b13..000000000000
--- a/make_install.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- Makefile_raw 2017-04-03 22:32:08.000000000 +0200
-+++ Makefile 2017-04-11 09:10:58.900793485 +0200
-@@ -171,7 +171,7 @@
- ./therion --print-init-file > therion.ini
-
- install: all
-- tclsh makeinstall.tcl $(THPLATFORM)
-+ tclsh makeinstall.tcl $(THPLATFORM) $(DESTDIR)
-
- minor-release:
- perl makerelease.pl
---- makeinstall.tcl_raw 2017-04-03 22:32:08.000000000 +0200
-+++ makeinstall.tcl 2017-04-11 09:15:00.960791964 +0200
-@@ -2,6 +2,7 @@
- set instdir /usr/local
- if {$argc > 0} {
- set platform [lindex $argv 0]
-+ set instdir [lindex $argv 1]
- } else {
- if {[string equal $tcl_platform(platform) windows]} {
- set platform WIN32
-@@ -10,6 +11,8 @@
-
- proc copyfile {force src dst} {
- if {$force} {
-+ set dirname [file dirname $dst]
-+ file mkdir $dirname
- if {[catch {
- file copy -force -- $src $dst
- }]} {
-@@ -50,9 +53,9 @@
- copyfile 0 xtherion/xtherion.ini /etc/xtherion.ini
- file attributes /etc/xtherion.ini -permissions 0644
- } else {
-- copyfile 1 therion $instdir/bin/therion
-- copyfile 1 xtherion/xtherion $instdir/bin/xtherion
-- copyfile 1 loch/loch $instdir/bin/loch
-+ copyfile 1 therion $instdir/usr/bin/therion
-+ copyfile 1 xtherion/xtherion $instdir/usr/bin/xtherion
-+ copyfile 1 loch/loch $instdir/usr/bin/loch
- copyfile 1 therion.ini $instdir/etc/therion.ini.new
- copyfile 1 xtherion/xtherion.ini $instdir/etc/xtherion.ini.new
- copyfile 0 therion.ini $instdir/etc/therion.ini