summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG3
-rwxr-xr-xPKGBUILD6
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4e1bf469a81..83203285de8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = therion
pkgdesc = Cave surveying: processes survey data and generates maps or 3D models of caves
pkgver = 5.5.6
- pkgrel = 1
+ pkgrel = 2
url = http://therion.speleo.sk
changelog = CHANGELOG
arch = x86_64
@@ -19,7 +19,7 @@ pkgbase = therion
depends = tk
depends = tkimg
depends = vtk
- depends = wxgtk
+ depends = wxgtk3
depends = zlib
backup = etc/therion.ini
backup = etc/xtherion.ini
diff --git a/CHANGELOG b/CHANGELOG
index 6d47c5666557..a6ac7a225432 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -16,3 +16,6 @@
- enable parallel execution
- add ini files to backup
- remove depends: webkitgtk2
+
+# 5.5.6-2 - 2021-01-17 - Thomas Holder
+- use wxgtk3
diff --git a/PKGBUILD b/PKGBUILD
index 7dadeba67ee4..425d4ac1bfc1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='therion'
pkgver='5.5.6'
-pkgrel='1'
+pkgrel='2'
pkgdesc="Cave surveying: processes survey data and generates maps or 3D models of caves"
arch=('x86_64' 'i686')
url="http://therion.speleo.sk"
@@ -23,7 +23,7 @@ depends=(
'tk'
'tkimg'
'vtk'
- 'wxgtk'
+ 'wxgtk3'
'zlib'
)
@@ -56,6 +56,8 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
+ export WX_CONFIG="wx-config-gtk3"
+
# avoid parallel-execution errors
make version thchencdata.h thmpost.h
make therion