summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7a8771b9dc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = thes-git
+ pkgdesc = A CLI tool that finds the location of IP addresses.
+ pkgver = 0.1.2.r0.g2c88e93
+ pkgrel = 1
+ url = https://github.com/DefunctLizard/thes
+ arch = x86_64
+ license = APACHE-2.0
+ makedepends = rust
+ makedepends = git
+ depends = glibc
+ source = thes::git+https://github.com/DefunctLizard/thes.git
+ md5sums = SKIP
+
+pkgname = thes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c873d3e5cfe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grant Handy <grantshandy AT gmail DOT com>
+
+_pkgname='thes'
+pkgname=${_pkgname}-git
+pkgver=0.1.2.r0.g2c88e93
+pkgrel=1
+pkgdesc="A CLI tool that finds the location of IP addresses."
+arch=('x86_64')
+url="https://github.com/DefunctLizard/thes"
+license=('APACHE-2.0')
+depends=('glibc')
+makedepends=('rust' 'git')
+source=("${_pkgname}::git+https://github.com/DefunctLizard/thes.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+
+ # Binary
+ install -Dm755 target/release/$_pkgname $pkgdir/usr/bin/$_pkgname
+}