summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1afc6d93844..64097791de1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = theslate
pkgdesc = Text Editor with code highlighting support
- pkgver = 0.2
+ pkgver = 0.3
pkgrel = 0
url = https://github.com/vicr123/theslate
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = theslate
depends = qtermwidget
depends = the-libs
depends = qt5-websockets
- source = theslate-0.2::git+https://github.com/vicr123/theslate.git
+ source = theslate-0.3::git+https://github.com/vicr123/theslate.git
md5sums = SKIP
pkgname = theslate
diff --git a/PKGBUILD b/PKGBUILD
index 8f8d4d6af381..9420d8b04db9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theslate
-pkgver=0.2
+pkgver=0.3
pkgrel=0
pkgdesc="Text Editor with code highlighting support"
arch=("x86_64")
@@ -18,10 +18,6 @@ build() {
}
package() {
- mkdir -p "$pkgdir/usr/bin"
- cp "$pkgname-$pkgver/theslate" "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
- cp "$pkgname-$pkgver/theslate.desktop" "$pkgdir/usr/share/applications"
- mkdir -p "$pkgdir/usr/share/icons"
- cp "$srcdir/$pkgname-$pkgver/icons/icon.svg" "$pkgdir/usr/share/icons/theslate.svg"
+ cd "$pkgname-$pkgver"
+ make install INSTALL_ROOT=$pkgdir
}