summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 186c2ace1f53..046295ef3138 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = theslate
pkgdesc = Text Editor with code highlighting support
- pkgver = 0.3
+ pkgver = 1.0
pkgrel = 0
url = https://github.com/vicr123/theslate
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = qt5-tools
depends = xdg-utils
depends = qt5-base
- depends = qtermwidget
depends = the-libs
- depends = qt5-websockets
+ depends = qt5-webengine
depends = qt5-svg
- source = theslate-0.3::git+https://github.com/vicr123/theslate.git
- md5sums = SKIP
+ depends = syntax-highlighting
+ source = theslate-1.0::git+https://github.com/vicr123/theSlate.git
+ sha256sums = SKIP
pkgname = theslate
diff --git a/PKGBUILD b/PKGBUILD
index d1da2cc79d48..ff7386b430ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theslate
-pkgver=0.3
+pkgver=1.0
pkgrel=0
pkgdesc="Text Editor with code highlighting support"
arch=("x86_64")
url="https://github.com/vicr123/theslate"
license=('GPL3')
-depends=('xdg-utils' 'qt5-base' 'qtermwidget' 'the-libs' 'qt5-websockets' 'qt5-svg')
-makedepends=('git')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theslate.git')
-md5sums=('SKIP')
+depends=('xdg-utils' 'qt5-base' 'the-libs' 'qt5-webengine' 'qt5-svg' 'syntax-highlighting')
+makedepends=('git' 'qt5-tools')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theSlate.git')
+sha256sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
+ git checkout tags/v$pkgver
+ git submodule init
+ git submodule update
qmake
make
}