summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..238e84b7807c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = theslate
+ pkgdesc = Text Editor with code highlighting support
+ pkgver = 0.2
+ pkgrel = 0
+ url = https://github.com/vicr123/theslate
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = xdg-utils
+ depends = qt5-base
+ source = theslate-0.2::git+https://github.com/vicr123/theslate.git
+ md5sums = SKIP
+
+pkgname = theslate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48e36629e236
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=theslate
+pkgver=0.2
+pkgrel=0
+pkgdesc="Text Editor with code highlighting support"
+arch=("x86_64")
+url="https://github.com/vicr123/theslate"
+license=('GPL3')
+depends=('xdg-utils' 'qt5-base')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theslate.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "$pkgname-$pkgver/theslate" "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "$pkgname-$pkgver/theslate.desktop" "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons"
+ cp "$srcdir/$pkgname-$pkgver/icons/icon.svg" "$pkgdir/usr/share/icons/theslate.svg"
+}