summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD26
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..937f4243249f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = thingy
+ pkgdesc = Utility application used to make collections and quickly access recent and favorite documents.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/linuxmint/thingy
+ arch = any
+ license = GPL3
+ depends = python-gobject
+ depends = python-setproctitle
+ depends = xapp
+ depends = xreader
+ source = thingy-1.0.1.tar.gz::https://github.com/linuxmint/thingy/archive/refs/tags/1.0.1.tar.gz
+ sha256sums = 5efde7cd367d16c680306e7fb036bc513a514bfd8486741e7a100eec90afd1bf
+
+pkgname = thingy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e4b8b8bb27a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=thingy
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Utility application used to make collections and quickly access recent and favorite documents."
+arch=('any')
+url="https://github.com/linuxmint/thingy"
+license=('GPL3')
+depends=('python-gobject' 'python-setproctitle' 'xapp' 'xreader')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('5efde7cd367d16c680306e7fb036bc513a514bfd8486741e7a100eec90afd1bf')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ sed -i "s/__DEB_VERSION__/${pkgver//+*/}/g" "usr/lib/$pkgname/$pkgname.py"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -r usr "$pkgdir"
+}