summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
-rw-r--r--thinkfan.service7
4 files changed, 31 insertions, 23 deletions
diff --git a/.AURINFO b/.AURINFO
index 9df60e4f24cc..f76c8a934119 100644
--- a/.AURINFO
+++ b/.AURINFO
@@ -1,19 +1,23 @@
pkgbase = thinkfan
pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
- pkgver = 0.9.2
- pkgrel = 2
- url = http://thinkfan.sourceforge.net/
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/vmatare/thinkfan
install = thinkfan.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
depends = libatasmart
+ depends = yaml-cpp
optdepends = lm_sensors: hwmon support
- source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.2.tar.gz
- source = thinkfan.install
+ backup = etc/systemd/system/thinkfan.service.d/override.conf
+ source = thinkfan-1.0.1.tar.gz::https://github.com/vmatare/thinkfan/archive/1.0.1.tar.gz
source = thinkfan.service
source = thinkpad_acpi.conf
+ sha256sums = df2497028206faf31a1e886e3529b44821a19b72e9dff11b530e008443300612
+ sha256sums = 5b743256afc30d8a2db840f16b03871abbe0a033dd1b0d3f1b7d5a544808271f
+ sha256sums = 28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f
pkgname = thinkfan
diff --git a/.SRCINFO b/.SRCINFO
index e7f57d2ff4c5..f76c8a934119 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
-# Generated by mksrcinfo v8
-# Thu May 5 10:22:47 UTC 2016
pkgbase = thinkfan
pkgdesc = A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi
- pkgver = 0.9.3
+ pkgver = 1.0.1
pkgrel = 1
- url = http://thinkfan.sourceforge.net/
+ url = https://github.com/vmatare/thinkfan
install = thinkfan.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
depends = libatasmart
+ depends = yaml-cpp
optdepends = lm_sensors: hwmon support
- source = http://downloads.sourceforge.net/project/thinkfan/thinkfan-0.9.3.tar.gz
+ backup = etc/systemd/system/thinkfan.service.d/override.conf
+ source = thinkfan-1.0.1.tar.gz::https://github.com/vmatare/thinkfan/archive/1.0.1.tar.gz
source = thinkfan.service
source = thinkpad_acpi.conf
- sha256sums = b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b
- sha256sums = 90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f
+ sha256sums = df2497028206faf31a1e886e3529b44821a19b72e9dff11b530e008443300612
+ sha256sums = 5b743256afc30d8a2db840f16b03871abbe0a033dd1b0d3f1b7d5a544808271f
sha256sums = 28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f
pkgname = thinkfan
diff --git a/PKGBUILD b/PKGBUILD
index 9f3c1ba44fb0..38c1b2a461e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,21 @@
# Contributor: Frederik Alkærsig (FALKER) <havnelisten AT gmail.com>
pkgname=thinkfan
-pkgver=0.9.3
+pkgver=1.0.1
pkgrel=1
pkgdesc="A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi"
-url="http://thinkfan.sourceforge.net/"
+url="https://github.com/vmatare/thinkfan"
arch=('i686' 'x86_64')
makedepends=('cmake')
-depends=('libatasmart')
+depends=('libatasmart' 'yaml-cpp')
optdepends=('lm_sensors: hwmon support')
+backup=('etc/systemd/system/thinkfan.service.d/override.conf')
license=('GPL')
-source=(http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver.tar.gz
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vmatare/$pkgname/archive/$pkgver.tar.gz"
'thinkfan.service'
'thinkpad_acpi.conf')
-sha256sums=('b61c634996c450445d7e440bf41f7adcda86506063f832afa40d44e01061e45b'
- '90f0270b4044a41315feb7bc1447ce4a0d5ee50178682e9a1d2a36b07c1a494f'
+sha256sums=('df2497028206faf31a1e886e3529b44821a19b72e9dff11b530e008443300612'
+ '5b743256afc30d8a2db840f16b03871abbe0a033dd1b0d3f1b7d5a544808271f'
'28874576641b3cc1aa486e1bc9ed40eadfe8b13d6d3014016e31fedc5dc5195f')
install=thinkfan.install
@@ -30,11 +31,13 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
install -d -m755 "$pkgdir"/usr/{bin,lib/{modprobe.d,systemd/system},share/{doc/"$pkgname"/{,examples},man/man1}}
+ install -d -m755 "$pkgdir"/etc/systemd/system/thinkfan.service.d
install -D -m755 "$pkgname" "$pkgdir"/usr/bin
- install -D -m644 README NEWS "$pkgdir"/usr/share/doc/"$pkgname"
+ install -D -m644 README "$pkgdir"/usr/share/doc/"$pkgname"
install -D -m644 examples/* "$pkgdir"/usr/share/doc/"$pkgname"/examples
install -D -m644 src/"$pkgname".1 "$pkgdir"/usr/share/man/man1
- install -D -m644 ../"$pkgname".service "$pkgdir"/usr/lib/systemd/system
+ install -D -m644 ../"$pkgname".service rcscripts/systemd/thinkfan-wakeup.service "$pkgdir"/usr/lib/systemd/system
+ install -D -m644 rcscripts/systemd/override.conf "$pkgdir"/etc/systemd/system/thinkfan.service.d
install -D -m644 ../thinkpad_acpi.conf "$pkgdir"/usr/lib/modprobe.d
}
diff --git a/thinkfan.service b/thinkfan.service
index 5618aed6fe7c..e8a218161337 100644
--- a/thinkfan.service
+++ b/thinkfan.service
@@ -5,9 +5,10 @@ After=lm_sensors.service
[Service]
Type=forking
-ExecStart=/usr/bin/thinkfan
-PIDFile=/var/run/thinkfan.pid
-ExecReload=/usr/bin/kill -HUP $MAINPID
+ExecStart=/usr/bin/thinkfan $THINKFAN_ARGS
+PIDFile=/run/thinkfan.pid
+ExecReload=/bin/kill -HUP $MAINPID
[Install]
WantedBy=multi-user.target
+Also=thinkfan-wakeup.service