summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
-rw-r--r--thomaswasalone-hib.desktop10
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1837db6d4405
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = thomaswasalone-hib
+ pkgdesc = Thomas Was Alone, a minimalistic puzzle-platformer (Humble Bundle version)
+ pkgver = 0_20130429
+ pkgrel = 2
+ url = http://www.thomaswasalone.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = lib32-glu
+ depends = lib32-libxcursor
+ depends = lib32-alsa-lib
+ depends = lib32-gcc-libs
+ optdepends = lib32-alsa-plugins: PulseAudio support
+ optdepends = lib32-libpulse: PulseAudio support
+ options = !strip
+ options = !upx
+ source = hib://thomaswasalone-linux-1369349552.tar
+ source = thomaswasalone-hib.desktop
+ md5sums = e7f8e766188718e16880b1137c430f35
+ md5sums = 8fe996d4b1a2b3ded634a9d487ea8893
+
+pkgname = thomaswasalone-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a61c375bc20e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=thomaswasalone-hib
+pkgver=0_20130429
+_hibver=1369349552
+pkgrel=2
+pkgdesc='Thomas Was Alone, a minimalistic puzzle-platformer (Humble Bundle version)'
+url='http://www.thomaswasalone.com/'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+if [ $CARCH == i686 ]; then
+ depends=('glu' 'libxcursor' 'alsa-lib' 'gcc-libs')
+ optdepends=('alsa-plugins: PulseAudio support')
+else
+ depends=('lib32-glu' 'lib32-libxcursor' 'lib32-alsa-lib' 'lib32-gcc-libs')
+ optdepends=('lib32-alsa-plugins: PulseAudio support'
+ 'lib32-libpulse: PulseAudio support')
+fi
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=("hib://thomaswasalone-linux-${_hibver}.tar"
+ 'thomaswasalone-hib.desktop')
+md5sums=('e7f8e766188718e16880b1137c430f35'
+ '8fe996d4b1a2b3ded634a9d487ea8893')
+
+package() {
+ cd $srcdir
+ _installdir="/opt/ThomasWasAlone"; _target="$pkgdir/$_installdir"
+
+ # Fix permissions
+ find "thomasLinuxStandalone" -type f -exec chmod 644 {} \;
+ find "thomasLinuxStandalone" -type d -exec chmod 755 {} \;
+ chmod 755 "thomasLinuxStandalone/thomasWasAlone"
+
+ # Install game files
+ mkdir -p $_target
+ cp -rT "thomasLinuxStandalone" "$_target"
+
+ # Install desktop entry
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # Install icon
+ install -Dm644 "$_target/thomasWasAlone_Data/Resources/UnityPlayer.png" \
+ "$pkgdir/usr/share/pixmaps/thomaswasalone.png"
+
+ # Install launcher script
+ echo -e "#!/bin/sh\ncd $_installdir && ./thomasWasAlone" > "launcher.sh"
+ install -Dm755 "launcher.sh" "$pkgdir/usr/bin/thomaswasalone"
+}
diff --git a/thomaswasalone-hib.desktop b/thomaswasalone-hib.desktop
new file mode 100644
index 000000000000..9cb4a1337f13
--- /dev/null
+++ b/thomaswasalone-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Thomas Was Alone
+Comment=Mike Bithell
+GenericName=Platformer Puzzle Game
+Icon=thomaswasalone
+Exec=/usr/bin/thomaswasalone
+Terminal=false