summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd86ea1bf05..26373cfe8ab4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = thonny-git
pkgdesc = Python IDE for beginners.
- pkgver = r1403.40455c1
- pkgrel = 2
+ pkgver = r3936.c1da4858
+ pkgrel = 1
url = http://thonny.org/
arch = any
license = MIT
@@ -11,10 +11,11 @@ pkgbase = thonny-git
depends = python-jedi
depends = tcl
depends = tk
+ depends = python-distro
+ depends = python-pip
provides = thonny
conflicts = thonny
- source = git+https://bitbucket.org/plas/thonny.git
+ source = git+https://github.com/thonny/thonny.git
sha256sums = SKIP
pkgname = thonny-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 4644f3cbc1e7..f463346e7965 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=thonny-git
-pkgver=r1403.40455c1
-pkgrel=2
+pkgver=r3936.c1da4858
+pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
url="http://thonny.org/"
license=('MIT')
conflicts=("thonny")
provides=("thonny")
-depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk')
-source=("git+https://bitbucket.org/plas/thonny.git")
+depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk' 'python-distro' 'python-pip')
+source=("git+https://github.com/thonny/thonny.git")
sha256sums=('SKIP')
pkgver() {
@@ -19,8 +19,14 @@ pkgver() {
package() {
cd "$srcdir"
+ pip3 install --prefix="$pkgdir/usr" --force -I tkinterhtml
+
+ pyversion="$(ls $pkgdir/usr/lib | xargs)"
+
install -Dm 755 "thonny/packaging/linux/thonny" "$pkgdir/usr/bin/thonny"
+ sed -i "s/python3.7/$pyversion/g" "$pkgdir/usr/bin/thonny"
+
sed -i 's|$target_dir|/usr|' "thonny/packaging/linux/Thonny.desktop"
install -Dm 644 "thonny/packaging/linux/Thonny.desktop" \
"$pkgdir/usr/share/applications/thonny.desktop"
@@ -29,9 +35,7 @@ package() {
# Install.py currently does not allow for setting root for creating a package
# Files must by copied manually for now in section below.
- install -d 644 "$pkgdir/usr/lib/python3.6/site-packages/thonny"
+ install -d 644 "$pkgdir/usr/lib/$pyversion/site-packages/thonny"
cp -dr --no-preserve=ownership "thonny/thonny" \
- "$pkgdir/usr/lib/python3.6/site-packages"
-
- pip3 install --install-option="--prefix=$pkgdir/usr" --force distro tkinterhtml
+ "$pkgdir/usr/lib/$pyversion/site-packages"
}