summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f48c3c7b645..514754eea325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thonny-git
pkgdesc = Python IDE for beginners.
- pkgver = r3934.3482d717
+ pkgver = r3936.c1da4858
pkgrel = 1
url = http://thonny.org/
arch = any
@@ -11,6 +11,7 @@ pkgbase = thonny-git
depends = python-jedi
depends = tcl
depends = tk
+ depends = python-distro
provides = thonny
conflicts = thonny
source = git+https://github.com/thonny/thonny.git
diff --git a/PKGBUILD b/PKGBUILD
index f102e18f6cf6..21064fbee0cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=thonny-git
-pkgver=r3934.3482d717
+pkgver=r3936.c1da4858
pkgrel=1
pkgdesc="Python IDE for beginners."
arch=('any')
@@ -7,7 +7,7 @@ url="http://thonny.org/"
license=('MIT')
conflicts=("thonny")
provides=("thonny")
-depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk')
+depends=('openssl' 'python' 'python-beautifulsoup4' 'python-jedi' 'tcl' 'tk' 'python-distro')
source=("git+https://github.com/thonny/thonny.git")
sha256sums=('SKIP')
@@ -19,8 +19,14 @@ pkgver() {
package() {
cd "$srcdir"
+ pip3 install --prefix="$pkgdir/usr" --force -I tkinterhtml
+
+ pyversion="$(ls $pkgdir/usr/lib | xargs)"
+
install -Dm 755 "thonny/packaging/linux/thonny" "$pkgdir/usr/bin/thonny"
+ sed -i "s/python3.7/$pyversion/g" "$pkgdir/usr/bin/thonny"
+
sed -i 's|$target_dir|/usr|' "thonny/packaging/linux/Thonny.desktop"
install -Dm 644 "thonny/packaging/linux/Thonny.desktop" \
"$pkgdir/usr/share/applications/thonny.desktop"
@@ -29,9 +35,7 @@ package() {
# Install.py currently does not allow for setting root for creating a package
# Files must by copied manually for now in section below.
- install -d 644 "$pkgdir/usr/lib/python3.6/site-packages/thonny"
+ install -d 644 "$pkgdir/usr/lib/$pyversion/site-packages/thonny"
cp -dr --no-preserve=ownership "thonny/thonny" \
- "$pkgdir/usr/lib/python3.6/site-packages"
-
- pip3 install --prefix="$pkgdir/usr" --force distro tkinterhtml
+ "$pkgdir/usr/lib/$pyversion/site-packages"
}