summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
3 files changed, 51 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..bc030d62452d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = thrax
+ pkgdesc = tool from OpenGrm to compile grammars into weighted finite-state transducers
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://www.opengrm.org/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = openfst
+ source = http://openfst.cs.nyu.edu/twiki/pub/GRM/ThraxDownload/thrax-1.1.0.tar.gz
+
+pkgname = thrax
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9563cd3716ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = thrax
+ pkgdesc = tool from OpenGrm to compile grammars into weighted finite-state transducers
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://www.opengrm.org/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = openfst
+ source = http://openfst.cs.nyu.edu/twiki/pub/GRM/ThraxDownload/thrax-1.1.0.tar.gz
+ md5sums = 1d81d9999e7d95b30b6ba8a1f20853c0
+
+pkgname = thrax
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70b0534ef030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Benoit Favre <benoit.favre@gmail.com>
+
+pkgname=thrax
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="tool from OpenGrm to compile grammars into weighted finite-state transducers"
+arch=('i686' 'x86_64')
+url="http://www.opengrm.org/"
+license=('APACHE')
+depends=('openfst')
+source=("http://openfst.cs.nyu.edu/twiki/pub/GRM/ThraxDownload/${pkgname}-${pkgver}.tar.gz")
+md5sums=('1d81d9999e7d95b30b6ba8a1f20853c0')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ ./configure LDFLAGS=-L/usr/lib/fst
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}