summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD54
-rw-r--r--maven-repo-path.patch22
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23f595dfe5bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+# Generated by mksrcinfo v8
+# Fri Apr 29 06:26:42 UTC 2016
+pkgbase = thrift-java
+ pkgdesc = Java bindings for Thrift, a scalable cross-language services framework for IPC/RPC
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = http://thrift.apache.org/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libtool
+ makedepends = apache-ant
+ makedepends = java-environment
+ depends = zlib
+ depends = libevent
+ depends = openssl
+ depends = java-runtime
+ optdepends = thrift-base: for the Thrift compiler
+ optdepends = vim-thrift: for syntax highlighting in vim
+ options = !emptydirs
+ options = !makeflags
+ source = http://www.apache.org/dist/thrift/0.9.1/thrift-0.9.1.tar.gz
+ source = maven-repo-path.patch
+ md5sums = d2e46148f6e800a9492dbd848c66ab6e
+ md5sums = bfcb3b12a8c07d5d0d9e96a7e712a74c
+
+pkgname = thrift-java
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5db8b5a08abf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Contributor: Jochen Schalanda <jochen+aur@schalanda.name>
+# Contributor: Byron Clark <byron@theclarkfamily.name>
+pkgname=thrift-java
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Java bindings for Thrift, a scalable cross-language services framework for IPC/RPC"
+arch=(i686 x86_64)
+url="http://thrift.apache.org/"
+license=(APACHE)
+depends=(zlib libevent openssl java-runtime)
+makedepends=(automake autoconf libtool apache-ant java-environment)
+optdepends=(
+ 'thrift-base: for the Thrift compiler'
+ 'vim-thrift: for syntax highlighting in vim')
+options=(!emptydirs !makeflags)
+source=(http://www.apache.org/dist/thrift/$pkgver/thrift-$pkgver.tar.gz
+ maven-repo-path.patch)
+md5sums=('d2e46148f6e800a9492dbd848c66ab6e'
+ 'bfcb3b12a8c07d5d0d9e96a7e712a74c')
+
+build() {
+ cd $srcdir/thrift-$pkgver
+
+ patch -p1 -i $srcdir/maven-repo-path.patch
+
+ # apache-ant is not installed in a normal path location
+ . /etc/profile.d/apache-ant.sh
+
+ ./configure --prefix=/usr \
+ --without-cpp \
+ --without-qt4 \
+ --without-c_glib \
+ --without-csharp \
+ --with-java \
+ --without-erlang \
+ --without-perl \
+ --without-php \
+ --without-php_extension \
+ --without-python \
+ --without-ruby \
+ --without-haskell \
+ --without-go \
+ --without-d
+
+ make
+}
+
+package() {
+ cd $srcdir/thrift-$pkgver
+ make DESTDIR=$pkgdir install
+ rm -r $pkgdir/usr/bin
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/maven-repo-path.patch b/maven-repo-path.patch
new file mode 100644
index 000000000000..e21ec48b3d70
--- /dev/null
+++ b/maven-repo-path.patch
@@ -0,0 +1,22 @@
+diff --git a/lib/java/build.xml b/lib/java/build.xml
+--- a/lib/java/build.xml
++++ b/lib/java/build.xml
+@@ -317,7 +317,9 @@
+ <artifact:writepom pomRefId="pom" file="${pom.xml}"/>
+
+ <!-- Download the dependencies -->
+- <artifact:dependencies filesetId="build-dependency-jars" pomRefId="pom"/>
++ <artifact:dependencies filesetId="build-dependency-jars" pomRefId="pom">
++ <localRepository path="${basedir}/local-repo"/>
++ </artifact:dependencies>
+
+ <!-- Copy the dependencies to the build/lib dir -->
+ <copy todir="${build.dir}/lib">
+@@ -327,6 +329,7 @@
+
+ <!-- Dependencies needed for testing -->
+ <artifact:dependencies filesetId="test-dependency-jars" useScope="runtime">
++ <localRepository path="${basedir}/local-repo"/>
+ <dependency groupId="org.slf4j" artifactId="slf4j-log4j12" version="1.5.8"/>
+ <dependency groupId="junit" artifactId="junit" version="4.4"/>
+ </artifact:dependencies>