summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--throttle-runtime-pm.rules4
-rwxr-xr-xthrottlectl32
4 files changed, 16 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d29b83ce8efe..b6ba64d8ef3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = throttlectl
pkgdesc = Command-line user discretion power managment utility
pkgver = 1
- pkgrel = 2
+ pkgrel = 3
url = https://bbs.archlinux.org/viewtopic.php?id=180762
arch = any
license = GPL
@@ -17,7 +17,7 @@ pkgbase = throttlectl
source = throttle-cut.service
source = powersave
source = performance
- sha512sums = 48fac136a0ff11bec6c7c5fc840f81dc2f04dea5fe1132b4af735940e1360cc320f6a59cac573a356bf7ab25166bbc2da6fb9faf981644196d277824a2219337
+ sha512sums = 224160daea80f89f4d09899e69898f828efabedf73b92d7f0509b208582ebbfb888699676a079070ba9214dad5df256f0da037de335667b6cfcda71a5d3457e2
sha512sums = 6254e73446a91ea7945b9e4db1a1047eb2055d93aee315006857711ab21cba140da3badcf5834d2628e4799494a069647d11aa378a9bac67691df8d8b3adc12f
sha512sums = 3d487961bf86254817fd099b888d6245bbf1e57622166dc8df378d639bfb1c0fc105646038be6093183be102294394b88cde382fe961f7606b68619af4a00595
sha512sums = d11ed5f4344f07507497e816ccd7612ffc6df70636ca5f4817a9ce6e3b190b3a17fb02c44c4bf648359f640e4c63cc0b0134968ff4d3d989ad05fa4c095b03d3
diff --git a/PKGBUILD b/PKGBUILD
index e1538ce5bc39..99a55bc9926e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=throttlectl
pkgver=1
-pkgrel=2
+pkgrel=3
pkgdesc="Command-line user discretion power managment utility"
arch=('any')
url="https://bbs.archlinux.org/viewtopic.php?id=180762"
@@ -14,7 +14,7 @@ source=('throttlectl'
'throttle-cut.service'
'powersave'
'performance')
-sha512sums=('48fac136a0ff11bec6c7c5fc840f81dc2f04dea5fe1132b4af735940e1360cc320f6a59cac573a356bf7ab25166bbc2da6fb9faf981644196d277824a2219337'
+sha512sums=('224160daea80f89f4d09899e69898f828efabedf73b92d7f0509b208582ebbfb888699676a079070ba9214dad5df256f0da037de335667b6cfcda71a5d3457e2'
'6254e73446a91ea7945b9e4db1a1047eb2055d93aee315006857711ab21cba140da3badcf5834d2628e4799494a069647d11aa378a9bac67691df8d8b3adc12f'
'3d487961bf86254817fd099b888d6245bbf1e57622166dc8df378d639bfb1c0fc105646038be6093183be102294394b88cde382fe961f7606b68619af4a00595'
'd11ed5f4344f07507497e816ccd7612ffc6df70636ca5f4817a9ce6e3b190b3a17fb02c44c4bf648359f640e4c63cc0b0134968ff4d3d989ad05fa4c095b03d3')
diff --git a/throttle-runtime-pm.rules b/throttle-runtime-pm.rules
index f4cac9a6c17e..8b5f8643a753 100644
--- a/throttle-runtime-pm.rules
+++ b/throttle-runtime-pm.rules
@@ -5,10 +5,6 @@ ACTION!="add", GOTO="runtime_pm_rules_end"
## Blacklisted Devices (USB Keyboard/Mouse, etc.)
# Logitec Unifying Reciever (occasionally disabled ?)
ATTR{idVendor}=="046d", ATTR{idProduct}=="c52b", GOTO="runtime_pm_rules_end"
-# Standard Microsystems Corp. 2 Port Hub (doesn't charge with runtime pm ?)
-ATTR{idVendor}=="0424", ATTR{idProduct}=="a700", GOTO="runtime_pm_rules_end"
-# Charge Sixaxis/Dualshock 3 (disconnect or charge too slowly with runtime pm ?)
-ATTR{idVendor}=="054c", ATTR{idProduct}=="0268", GOTO="runtime_pm_rules_end"
# Asynchronous power transitions
SUBSYSTEMS=="*" ATTR{power/async}=="disabled", ATTR{power/async}="enabled"
diff --git a/throttlectl b/throttlectl
index 9f1656a6b954..874da07f2463 100755
--- a/throttlectl
+++ b/throttlectl
@@ -93,8 +93,8 @@ while (( "$#" )); do
ht-off) HYPERTHREADS="0" ;; esac
[[ -z "${HYPERTHREADS}" ]] && \
case "${2}" in \
- off|powersave|start) HYPERTHREADS="0"; SHIFT="2" ;; \
- on|performance|stop) HYPERTHREADS="1"; SHIFT="2" ;; \
+ cut|off|powersave|start) HYPERTHREADS="0"; SHIFT="2" ;; \
+ full|on|performance|stop) HYPERTHREADS="1"; SHIFT="2" ;; \
check|status) check_ht; SHIFT="2" ;; esac
[[ -n "${HYPERTHREADS}" ]] && throttle_ht
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
@@ -106,8 +106,8 @@ while (( "$#" )); do
gov-cut) GOVERNOR="powersave" ;; esac
[[ -z "${GOVERNOR}" ]] && \
case "${2}" in \
- cut|powersave|start) GOVERNOR="powersave"; SHIFT="2" ;; \
- full|performance|stop) GOVERNOR="performance"; SHIFT="2" ;; \
+ cut|off|powersave|start) GOVERNOR="powersave"; SHIFT="2" ;; \
+ full|on|performance|stop) GOVERNOR="performance"; SHIFT="2" ;; \
check|status) check_gov; SHIFT="2" ;; esac
[[ -n "${GOVERNOR}" ]] && throttle_gov
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
@@ -119,8 +119,8 @@ while (( "$#" )); do
turbo-off) XPSTURBO="1" ;; esac
[[ -z "${XPSTURBO}" ]] && \
case "${2}" in \
- off|powersave|start) XPSTURBO="1"; SHIFT="2" ;; \
- on|performance|stop) XPSTURBO="0"; SHIFT="2" ;; \
+ cut|off|powersave|start) XPSTURBO="1"; SHIFT="2" ;; \
+ full|on|performance|stop) XPSTURBO="0"; SHIFT="2" ;; \
check|status) check_turbo; SHIFT="2" ;; esac
[[ -n "${XPSTURBO}" ]] && throttle_turbo
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
@@ -128,8 +128,8 @@ while (( "$#" )); do
;;
backlight)
case "${2}" in \
- off|0|powersave|start) BACKLIGHT="0"; SHIFT="2" ;; \
- on|1|performance|stop) BACKLIGHT="1"; SHIFT="2" ;; \
+ cut|off|0|powersave|start) BACKLIGHT="0"; SHIFT="2" ;; \
+ full|on|1|performance|stop) BACKLIGHT="1"; SHIFT="2" ;; \
2) BACKLIGHT="2"; SHIFT="2" ;; \
check|status) check_backlight; SHIFT="2" ;; esac
[[ -n "${BACKLIGHT}" ]] && throttle_backlight
@@ -142,8 +142,8 @@ while (( "$#" )); do
gpu-cut) NVPM="0" ;; esac
[[ -z "${NVPM}" ]] && \
case "${2}" in \
- full|performance|stop) NVPM="1"; SHIFT="2" ;; \
- cut|powersave|start) NVPM="0"; SHIFT="2" ;; \
+ cut|off|powersave|start) NVPM="0"; SHIFT="2" ;; \
+ full|on|performance|stop) NVPM="1"; SHIFT="2" ;; \
check|status) check_nvpm; SHIFT="2" ;; esac
[[ -n "${NVPM}" ]] && [[ -z "$(command -v nvidia-settings)" ]] && \
throttle_nvpm
@@ -205,21 +205,13 @@ while (( "$#" )); do
[[ "${CONTROL}" == "auto" ]] && \
[[ -n "$(printf ${i} | grep msr[${CORES}-$((${CORES} * 2 - 1))])" || \
-n "$(printf ${i} | grep machinecheck[${CORES}-$((${CORES} * 2 - 1))])" || \
- -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 046D\:C52B)" || \
- -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 054C\:0268)" || \
- -f "$(printf ${i} | sed 's|/power.*|/idVendor|g')" && \
- "$(cat $(printf ${i} | sed 's|/power.*|/idVendor|g'))" == "0424" && \
- "$(cat $(printf ${i} | sed 's|/power.*|/idProduct|g'))" == "a700" ]] && \
+ -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 046D\:C52B)" ]] && \
continue ; printf "${CONTROL}" > "${i}" & done &
# USB Autosuspend (with exceptions for devices by VID:PID)
for i in /sys/bus/usb/devices/*/power/autosuspend{,_delay_ms}; do \
[[ "${AUTOSUSPEND}" == "1" ]] && \
- [[ -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 046D\:C52B)" || \
- -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 054C\:0268)" || \
- -f "$(printf ${i} | sed 's|/power.*|/idVendor|g')" && \
- "$(cat $(printf ${i} | sed 's|/power.*|/idVendor|g'))" == "0424" && \
- "$(cat $(printf ${i} | sed 's|/power.*|/idProduct|g'))" == "a700" ]] && \
+ [[ -n "$(ls $(printf ${i} | sed 's|power.*||g')/*/ | grep 046D\:C52B)" ]] && \
continue ; printf -- "${AUTOSUSPEND}" > "${i}" & done &
# Powersaving for modules