summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a733973302a6..3204e83950bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thrust-git
pkgdesc = A C++ parallel programming library which resembles the C++ Standard Library
- pkgver = 1.9.4.28.g986d178b
+ pkgver = 1.9.10.40.gd9d7b510
pkgrel = 1
url = https://github.com/thrust/thrust
arch = any
@@ -12,6 +12,8 @@ pkgbase = thrust-git
provides = thrust
conflicts = thrust
source = git+https://github.com/thrust/thrust.git
+ source = git+https://github.com/thrust/cub.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = thrust-git
diff --git a/PKGBUILD b/PKGBUILD
index dff46f176a23..c8386ef8bcc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=thrust
pkgname=thrust-git
-pkgver=1.9.4.28.g986d178b
+pkgver=1.9.10.40.gd9d7b510
pkgrel=1
pkgdesc='A C++ parallel programming library which resembles the C++ Standard Library'
arch=('any')
@@ -19,19 +19,29 @@ optdepends=(
'intel-tbb: for TBB backend'
)
-source=("git+https://github.com/thrust/${_pkgname}.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/thrust/${_pkgname}.git"
+ "git+https://github.com/thrust/cub.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${_pkgname}"
git describe --always | sed -e 's|-|.|g'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule init
+ git config submodule.cub.url "${srcdir}/cub"
+ git submodule update
+}
+
package() {
install -dm 755 "${pkgdir}/opt/${_pkgname}"
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
cp -r ${_pkgname} "${pkgdir}/opt/${_pkgname}/"
cp -r examples "${pkgdir}/opt/${_pkgname}/"
+ cp -rL cub "${pkgdir}/opt/${_pkgname}/"
}
# vim: ft=sh ts=2 sw=2 et