summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--0001-Fix-file-roller-3.12.1-detection-bug-10826.patch37
-rw-r--r--PKGBUILD51
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c14e941bfee1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = thunar-archive-plugin-gtk2
+ pkgdesc = Create and extract archives in Thunar (GTK2 version)
+ pkgver = 0.3.1
+ pkgrel = 7
+ url = http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin
+ arch = x86_64
+ groups = xfce4-goodies
+ license = GPL2
+ makedepends = intltool
+ makedepends = xfce4-dev-tools
+ depends = thunar
+ depends = hicolor-icon-theme
+ optdepends = file-roller
+ optdepends = ark
+ optdepends = xarchiver
+ provides = thunar-archive-plugin
+ conflicts = thunar-archive-plugin
+ source = https://archive.xfce.org/src/thunar-plugins/thunar-archive-plugin/0.3/thunar-archive-plugin-0.3.1.tar.bz2
+ source = 0001-Fix-file-roller-3.12.1-detection-bug-10826.patch
+ sha256sums = 9ad559b0c11308f6897ad56604e5a06dc8f369f649eb20120b2d3018ef5da54c
+ sha256sums = 4373c3011f5abd1d4119d283e832aeb858c810f14b3a59b6250cf10893aa0757
+
+pkgname = thunar-archive-plugin-gtk2
+
diff --git a/0001-Fix-file-roller-3.12.1-detection-bug-10826.patch b/0001-Fix-file-roller-3.12.1-detection-bug-10826.patch
new file mode 100644
index 000000000000..f1435cd55d0b
--- /dev/null
+++ b/0001-Fix-file-roller-3.12.1-detection-bug-10826.patch
@@ -0,0 +1,37 @@
+From cc1b9c86d1b563318a2b9489b062f9519ae08b20 Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Wed, 23 Apr 2014 20:13:19 +0300
+Subject: [PATCH] Fix file-roller>=3.12.1 detection (bug #10826)
+
+File Roller 3.12.1 changed the name of its .desktop file from
+file-roller.desktop to org.gnome.FileRoller.desktop.
+
+We install a new symlink to support the new .desktop file name.
+---
+ scripts/Makefile.am | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4da529c..3804605 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -5,12 +5,15 @@ wrapper_SCRIPTS = \
+ ark.tap \
+ file-roller.tap
+
+-# Install symlink to 'gnome-file-roller.tap'
++# Install symlink to 'gnome-file-roller.tap' and 'org.gnome.FileRoller.tap'
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(wrapperdir)
+ -( cd $(DESTDIR)$(wrapperdir) ; \
+ test -f gnome-file-roller.tap \
+ || ln -sf file-roller.tap gnome-file-roller.tap )
++ -( cd $(DESTDIR)$(wrapperdir) ; \
++ test -f org.gnome.FileRoller.tap \
++ || ln -sf file-roller.tap org.gnome.FileRoller.tap )
+
+ EXTRA_DIST = \
+ $(wrapper_SCRIPTS) \
+--
+1.9.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0595ba72486c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Newb I the Newbd <czbd hostedon o2 halfacolon pl>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Tobias Kieslich <tobias (at) archlinux.org>
+
+_pkgbase=thunar-archive-plugin
+pkgname=(${_pkgbase}-gtk2)
+pkgver=0.3.1
+pkgrel=7
+pkgdesc="Create and extract archives in Thunar (GTK2 version)"
+arch=('x86_64')
+url="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+license=('GPL2')
+groups=('xfce4-goodies')
+conflicts=("${_pkgbase}")
+provides=("${_pkgbase}")
+depends=('thunar' 'hicolor-icon-theme')
+makedepends=('intltool' 'xfce4-dev-tools')
+optdepends=('file-roller'
+ 'ark'
+ 'xarchiver')
+source=(https://archive.xfce.org/src/thunar-plugins/thunar-archive-plugin/0.3/thunar-archive-plugin-$pkgver.tar.bz2
+ 0001-Fix-file-roller-3.12.1-detection-bug-10826.patch)
+sha256sums=('9ad559b0c11308f6897ad56604e5a06dc8f369f649eb20120b2d3018ef5da54c'
+ '4373c3011f5abd1d4119d283e832aeb858c810f14b3a59b6250cf10893aa0757')
+
+prepare() {
+ cd "$srcdir/thunar-archive-plugin-$pkgver"
+
+ # https://bugzilla.xfce.org/show_bug.cgi?id=10826
+ patch -Np1 -i ../0001-Fix-file-roller-3.12.1-detection-bug-10826.patch
+ NOCONFIGURE=1 xdt-autogen
+}
+
+build() {
+ cd "$srcdir/thunar-archive-plugin-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/thunar-archive-plugin-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: