summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f8e9948c3d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Nov 19 05:55:00 UTC 2017
+pkgbase = thunar-dropbox-git
+ pkgdesc = Plugin for thunar that adds context-menu items for dropbox.
+ pkgver = 0.2.1.r2.g61ba51b
+ pkgrel = 1
+ url = https://github.com/Maato/thunar-dropbox
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ makedepends = git
+ depends = thunar-git
+ source = thunar-dropbox::git+https://github.com/Maato/thunar-dropbox
+ source = thunarx-3-port.patch::https://github.com/twa022/thunar-dropbox/commit/2da13dc73c56cea4a1d3de19c4917467954f985d.patch
+ sha256sums = SKIP
+ sha256sums = ab12fdc792903a3e07fba3cd58c9553075a3bff672fcc45b561ccb7c5bb8e31c
+
+pkgname = thunar-dropbox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..765f8188df93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=thunar-dropbox
+pkgname=${_pkgname}-git
+pkgver=0.2.1.r2.g61ba51b
+pkgrel=1
+pkgdesc="Plugin for thunar that adds context-menu items for dropbox."
+arch=('i686' 'x86_64')
+url="https://github.com/Maato/thunar-dropbox"
+license=('GPL3')
+depends=('thunar-git')
+makedepends=('python2' 'git')
+source=("${_pkgname}::git+https://github.com/Maato/thunar-dropbox"
+ 'thunarx-3-port.patch::https://github.com/twa022/thunar-dropbox/commit/2da13dc73c56cea4a1d3de19c4917467954f985d.patch')
+sha256sums=('SKIP'
+ 'ab12fdc792903a3e07fba3cd58c9553075a3bff672fcc45b561ccb7c5bb8e31c')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r "s/([^-]*-g)/r\1/;s/-/./g"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -uNp1 -r- -i ../thunarx-3-port.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python2 waf install --destdir="${pkgdir}"
+}