summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 21 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94fa58deb531..3392273a05d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-# Generated by mksrcinfo v8
-# Sat Jul 7 14:53:05 UTC 2018
pkgbase = thunar-dropbox-git
- pkgdesc = Thunar plugin that adds dropbox context-menu (patched for thunarx-3)
- pkgver = 0.2.1+6+g5c3c178
+ pkgdesc = Plugin for Thunar that adds context-menu items for Dropbox.
+ pkgver = 0.3.1+0+gcb2070f
pkgrel = 1
- epoch = 1
- url = https://github.com/Maato/thunar-dropbox
+ url = https://github.com/Jeinzi/thunar-dropbox
arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = GPL3
- makedepends = python2
makedepends = git
- depends = thunar>=1.7.0
+ makedepends = cmake
+ depends = thunar
depends = dropbox
- source = thunar-dropbox::git+https://github.com/Jeinzi/thunar-dropbox#branch=dev-jeinzi
+ source = git+https://github.com/Jeinzi/thunar-dropbox
sha256sums = SKIP
pkgname = thunar-dropbox-git
diff --git a/PKGBUILD b/PKGBUILD
index 4c289cbda61b..13e5ddf70c3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,30 @@
_pkgname=thunar-dropbox
pkgname=${_pkgname}-git
-epoch=1
-pkgver=0.2.1+6+g5c3c178
+pkgver=0.3.1+0+gcb2070f
pkgrel=1
-pkgdesc="Thunar plugin that adds dropbox context-menu (patched for thunarx-3)"
-arch=('i686' 'x86_64')
-url="https://github.com/Maato/thunar-dropbox"
+pkgdesc="Plugin for Thunar that adds context-menu items for Dropbox."
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/Jeinzi/thunar-dropbox"
license=('GPL3')
-depends=('thunar>=1.7.0' 'dropbox')
-makedepends=('python2' 'git')
-#source=("${_pkgname}::git+https://github.com/Maato/thunar-dropbox"
-# 'thunarx-3-port.patch::https://github.com/twa022/thunar-dropbox/commit/2da13dc73c56cea4a1d3de19c4917467954f985d.patch')
-source=("${_pkgname}::git+https://github.com/Jeinzi/thunar-dropbox#branch=dev-jeinzi")
+depends=('thunar' 'dropbox')
+makedepends=('git' 'cmake')
+source=(git+https://github.com/Jeinzi/thunar-dropbox)
sha256sums=('SKIP')
-# 'ab12fdc792903a3e07fba3cd58c9553075a3bff672fcc45b561ccb7c5bb8e31c')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -r "s:-:+:g" #/([^-]*-g)/r\1/;s/-/./g"
+ git describe --long --tags | sed -r "s:-:+:g"
}
-#prepare() {
-# cd "${srcdir}/${_pkgname}"
-# patch -uNp1 -r- -i ../thunarx-3-port.patch
-#}
-
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
- python2 waf configure --prefix=/usr
- python2 waf build
+ cmake -B build -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" .
+ cmake --build build
}
package() {
- cd "${srcdir}/${_pkgname}"
- python2 waf install --destdir="${pkgdir}"
+ cd "${_pkgname}"
+ cmake --build build --target install --config Release
}