summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8be5c1587df5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = thunar-nextcloud-plugin
+ pkgdesc = A plugin for sharing files via the Nextcloud client from within the Thunar file manager
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/frederikmoellers/thunar-nextcloud-plugin
+ arch = x86_64
+ license = GPL-3
+ depends = thunar
+ depends = nextcloud-client
+ depends = gcc
+ depends = unzip
+ depends = gtk3
+ source = https://github.com/frederikmoellers/thunar-nextcloud-plugin/archive/3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip
+ sha256sums = d43e249fb9771a857dcca706a912cc631da7bbe259e5cdaac2a7eaa725ffda82
+
+pkgname = thunar-nextcloud-plugin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72aab3c8b9c9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+thunar-nextcloud-plugin*/
+*.zip
+src
+pkg
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b086cf9562ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dominik Schwaiger <mail@dominik-schwaiger.ch>
+pkgname=thunar-nextcloud-plugin
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc=" A plugin for sharing files via the Nextcloud client from within the Thunar file manager"
+arch=("x86_64")
+url="https://github.com/frederikmoellers/thunar-nextcloud-plugin"
+license=('GPL-3')
+groups=()
+depends=("thunar" "nextcloud-client" "gcc" "unzip" "gtk3")
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/frederikmoellers/thunar-nextcloud-plugin/archive/3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip")
+noextract=()
+sha256sums=("d43e249fb9771a857dcca706a912cc631da7bbe259e5cdaac2a7eaa725ffda82")
+validpgpkeys=()
+
+package() {
+ unzip -f 3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip
+ cd thunar-nextcloud-plugin-3015ee5bce2db072a2eeaa158150af2d7c0bfba6
+ bash compile.sh
+ install -D thunar-nextcloud-plugin.so "$pkgdir"/usr/lib/thunarx-3/thunar-nextcloud-plugin.so
+}