summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
-rw-r--r--run18
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef971f3adfb1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = thunder-mini
+ pkgdesc = Xunlei Product Center provides free download services for the latest products of Xunlei.
+ pkgver = 2.2.1
+ pkgrel = 0
+ url = https://dl.xunlei.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = wine
+ source = http://down.sandai.net/mini/ThunderMini_dl1.5.3.288.exe
+ source = license.html::https://www.xunlei.com/xieyi/xl9.html
+ source = file://run
+ md5sums = 95118524fa7d7e457c7bed4abcb5bbfc
+ md5sums = 381254665d06cdd2c9493a8892e32bc5
+ md5sums = 3c57bb9d9375bf00c11230caaf12ed5f
+
+pkgname = thunder-mini
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb9203b16513
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: qaz <fkxxyz@163.com>
+# Contributor: qaz <fkxxyz@163.com>
+
+pkgname=thunder-mini
+pkgver=2.2.1
+pkgrel=0
+pkgdesc="Xunlei Product Center provides free download services for the latest products of Xunlei."
+arch=("i686" "x86_64")
+url="https://dl.xunlei.com/"
+license=('custom')
+depends=('wine')
+source=(
+ "http://down.sandai.net/mini/ThunderMini_dl1.5.3.288.exe"
+ "license.html::https://www.xunlei.com/xieyi/xl9.html"
+ "file://run"
+)
+
+prepare() {
+ cd "${srcdir}"
+ 7z x -y ThunderMini_dl1.5.3.288.exe
+ rm ./Bin/UnInstallClean.exe
+}
+
+package() {
+
+ # Copy files
+ install -d "${pkgdir}/usr/share/$pkgname"
+ cp -r "$srcdir/"{Bin,bho,Skin} "${pkgdir}/usr/share/$pkgname/"
+ cp "$srcdir/\$WINDIR/system32/"* "${pkgdir}/usr/share/$pkgname/Bin/"
+ find "${pkgdir}/usr/share/$pkgname/" -type d -exec chmod 755 {} \;
+
+ # Run script
+ install -Dm755 run "${pkgdir}/usr/share/$pkgname/run"
+
+ # Install licenses
+ install -Dm644 "license.html" "${pkgdir}/usr/share/licenses/$pkgname/license.html"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('95118524fa7d7e457c7bed4abcb5bbfc'
+ '381254665d06cdd2c9493a8892e32bc5'
+ '3c57bb9d9375bf00c11230caaf12ed5f')
+ \ No newline at end of file
diff --git a/run b/run
new file mode 100644
index 000000000000..d4bfdd359bdf
--- /dev/null
+++ b/run
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+export WINEPREFIX=~/.wine-thunder-mini
+export WINEARCH=win32
+export WINEDEBUG=-all
+
+apphome="$(dirname "$(readlink -f "$0")")"
+workhome="$WINEPREFIX/drive_c/thunder-mini"
+
+if [ ! -e "${workhome}" ]; then
+ mkdir -p "$WINEPREFIX/drive_c"
+ ln -s "/usr/share/thunder-mini" "${workhome}"
+fi
+
+shellexe="$1"
+shift
+exec wine "C:\\thunder-mini\\Bin\\ThunderMini.exe" "$@"
+