summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
-rw-r--r--rust-1.33.patch39
-rw-r--r--rust-1.35.patch47
4 files changed, 65 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44690721865e..f8657f086727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thunderbird-appmenu
pkgdesc = Thunderbird from extra with appmenu patch
- pkgver = 60.7.2
+ pkgver = 60.8.0
pkgrel = 1
url = https://aur.archlinux.org/packages/thunderbird-appmenu/
arch = x86_64
@@ -35,17 +35,20 @@ pkgbase = thunderbird-appmenu
depends = ttf-font
depends = icu
optdepends = libcanberra: sound support
- provides = thunderbird=60.7.2
+ provides = thunderbird=60.8.0
conflicts = thunderbird
options = !emptydirs
options = !makeflags
- source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/60.7.2/source/thunderbird-60.7.2.source.tar.xz
+ source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/60.8.0/source/thunderbird-60.8.0.source.tar.xz
+ source = https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/60.8.0/source/thunderbird-60.8.0.source.tar.xz.asc
+ source = rust-1.35.patch
source = thunderbird.desktop
- source = rust-1.33.patch
source = unity-menubar.patch
- sha256sums = fc89a5f66b17d554fc0b9c153483edcc74b1bacc916dfd6dccead8478060af31
+ validpgpkeys = 14F26682D0916CDD81E37B6D61B7B526D98F0353
+ sha256sums = 1e7a13e64b63476d2235aaac6823fdab949af45cfcd5a25ee710cbae08c2f5d1
+ sha256sums = SKIP
+ sha256sums = 3257987cc0ab0559c65561d523eb4d0e73b5edb86d9d18a2487818d9fca0bb30
sha256sums = 3534ea85d8e0e35dba5f40a7a07844df19f3a480e1358fc50c2502f122dab789
- sha256sums = 2b0244a9f7a30f28bcc12055f171e5506c7e3b929d85c3b3514b7e4e4c251784
sha256sums = 22786f52773b93046fdb12378f67343b1d7d3390e83a00ff4aa03948c2b1c9e2
pkgname = thunderbird-appmenu
diff --git a/PKGBUILD b/PKGBUILD
index 5e9ff196488b..e6a591c35952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=thunderbird
pkgname=thunderbird-appmenu
-pkgver=60.7.2
+pkgver=60.8.0
pkgrel=1
pkgdesc="Thunderbird from extra with appmenu patch"
arch=(x86_64)
@@ -22,14 +22,16 @@ optdepends=('libcanberra: sound support')
provides=("thunderbird=$pkgver")
conflicts=("thunderbird")
options=(!emptydirs !makeflags)
-source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz
+source=(https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/$pkgver/source/thunderbird-$pkgver.source.tar.xz{,.asc}
+ rust-1.35.patch
$_pkgname.desktop
- rust-1.33.patch
unity-menubar.patch)
-sha256sums=('fc89a5f66b17d554fc0b9c153483edcc74b1bacc916dfd6dccead8478060af31'
+sha256sums=('1e7a13e64b63476d2235aaac6823fdab949af45cfcd5a25ee710cbae08c2f5d1'
+ 'SKIP'
+ '3257987cc0ab0559c65561d523eb4d0e73b5edb86d9d18a2487818d9fca0bb30'
'3534ea85d8e0e35dba5f40a7a07844df19f3a480e1358fc50c2502f122dab789'
- '2b0244a9f7a30f28bcc12055f171e5506c7e3b929d85c3b3514b7e4e4c251784'
'22786f52773b93046fdb12378f67343b1d7d3390e83a00ff4aa03948c2b1c9e2')
+validpgpkeys=(14F26682D0916CDD81E37B6D61B7B526D98F0353) # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -46,8 +48,8 @@ _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
prepare() {
cd $_pkgname-$pkgver
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1539901 (Patch from Fedora)
- patch -Np1 -i ../rust-1.33.patch
+ # # Fix build with rust 1.35 (Fedora)
+ patch -Np1 -i ../rust-1.35.patch
# actual appmenu patch from ubuntu repos
patch -Np1 -i ../unity-menubar.patch
diff --git a/rust-1.33.patch b/rust-1.33.patch
deleted file mode 100644
index f4b19bcf1232..000000000000
--- a/rust-1.33.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -up thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py
---- thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py.rust-1.33-build 2019-03-04 19:17:31.000000000 +0100
-+++ thunderbird-60.5.3/servo/components/style/gecko/regen_atoms.py 2019-03-13 15:05:58.965726109 +0100
-@@ -202,6 +202,7 @@ RULE_TEMPLATE = ('("{atom}") =>\n '
- ' }}}};')
-
- MACRO = '''
-+/// Returns a static atom by passing the literal string it represents.
- #[macro_export]
- macro_rules! atom {{
- {}
-diff -up thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs
---- thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs.rust-1.33-build 2019-03-04 19:17:30.000000000 +0100
-+++ thunderbird-60.5.3/servo/components/style/properties/properties.mako.rs 2019-03-13 15:05:58.966726107 +0100
-@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
-
- pub use self::declaration_block::*;
-
-+/// Generated
- #[cfg(feature = "gecko")]
- #[macro_export]
- macro_rules! property_name {
-@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
- }
- }
-
--// NOTE(emilio): Callers are responsible to deal with prefs.
-+/// Callers are responsible to deal with prefs.
- #[macro_export]
- macro_rules! css_properties_accessors {
- ($macro_name: ident) => {
-@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
- }
- }
-
-+/// Neco
- #[macro_export]
- macro_rules! longhand_properties_idents {
- ($macro_name: ident) => {
diff --git a/rust-1.35.patch b/rust-1.35.patch
new file mode 100644
index 000000000000..746145fac95a
--- /dev/null
+++ b/rust-1.35.patch
@@ -0,0 +1,47 @@
+diff -up thunderbird-60.8.0/servo/components/style_traits/values.rs.rust-1.33-build thunderbird-60.8.0/servo/components/style_traits/values.rs
+--- thunderbird-60.8.0/servo/components/style_traits/values.rs.rust-1.33-build 2019-07-03 17:25:28.000000000 +0200
++++ thunderbird-60.8.0/servo/components/style_traits/values.rs 2019-07-11 13:38:53.687318154 +0200
+@@ -135,6 +135,7 @@ where
+ }
+ }
+
++/// Some comment
+ #[macro_export]
+ macro_rules! serialize_function {
+ ($dest: expr, $name: ident($( $arg: expr, )+)) => {
+@@ -404,6 +405,7 @@ impl_to_css_for_predefined_type!(::csspa
+ impl_to_css_for_predefined_type!(::cssparser::Color);
+ impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
+
++/// Some comment
+ #[macro_export]
+ macro_rules! define_css_keyword_enum {
+ (pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {
+diff -up thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs.old thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs
+--- thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs.old 2019-07-11 14:22:51.393784701 +0200
++++ thunderbird-60.8.0/servo/components/style/properties/properties.mako.rs 2019-07-11 14:24:03.182578100 +0200
+@@ -55,6 +55,7 @@ use style_adjuster::StyleAdjuster;
+
+ pub use self::declaration_block::*;
+
++/// Neco
+ #[cfg(feature = "gecko")]
+ #[macro_export]
+ macro_rules! property_name {
+@@ -3852,7 +3853,7 @@ impl fmt::Debug for AliasId {
+ }
+ }
+
+-// NOTE(emilio): Callers are responsible to deal with prefs.
++/// NOTE(emilio): Callers are responsible to deal with prefs.
+ #[macro_export]
+ macro_rules! css_properties_accessors {
+ ($macro_name: ident) => {
+@@ -3875,6 +3876,7 @@ macro_rules! css_properties_accessors {
+ }
+ }
+
++/// Neco
+ #[macro_export]
+ macro_rules! longhand_properties_idents {
+ ($macro_name: ident) => {