summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5598c372939e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = thunderbolt-dkms-git
+ pkgdesc = DKMS Package for the thunderbolt driver
+ pkgver = 14d71aa
+ pkgrel = 1
+ url = https://github.com/dell/thunderbolt-dkms
+ arch = x86_64
+ license = GPL2
+ depends = dkms
+ optdepends = linux-headers
+ optdepends = linux-lts-headers
+ source = git+https://github.com/dell/thunderbolt-dkms.git
+ sha1sums = SKIP
+
+pkgname = thunderbolt-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59683e46d4b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Vincent Ambo <tazjin@gmail.com>
+
+_pkgname=thunderbolt-dkms
+pkgname=thunderbolt-dkms-git
+pkgver=14d71aa
+pkgrel=1
+pkgdesc="DKMS Package for the thunderbolt driver"
+arch=('x86_64')
+url="https://github.com/dell/thunderbolt-dkms"
+# No license file in repo yet, but see discussion on Github:
+# https://github.com/dell/thunderbolt-icm-dkms/issues/1
+license=('GPL2')
+depends=('dkms')
+optdepends=('linux-headers' 'linux-lts-headers')
+source=('git+https://github.com/dell/thunderbolt-dkms.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ local dest="${pkgdir}/usr/src/${_pkgname}-${pkgver}"
+
+ mkdir -p "${dest}"
+ cp "${srcdir}/${_pkgname}/thunderbolt"/* "${dest}"
+}