summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
-rw-r--r--tibia-starter.patch12
-rwxr-xr-xtibia.sh4
5 files changed, 44 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7798c7f089e..b048a148c1eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
+# Generated by mksrcinfo v8
+# Fri Sep 23 01:17:04 UTC 2016
pkgbase = tibia
pkgdesc = A fast-paced free massively multiplayer online role-playing game.
- pkgver = 1096
- pkgrel = 2
+ pkgver = 11.00.3839
+ pkgrel = 1
url = http://www.tibia.com
- arch = i686
arch = x86_64
license = custom
makedepends = gendesk
makedepends = python-html2text
- source = http://static.tibia.com/download/tibia1096.tgz
+ depends = glu
+ depends = libgl
+ depends = libice
+ depends = libxext
+ depends = pcre
+ depends = qt5-base
+ depends = qt5-declarative
+ source = tibia-11.00.3839.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz
source = http://www.tibia.com/support/agreement.php
- source = tibia.sh
- sha256sums = 11bec465da38ae8e6d4d773c54142fa38b6f99207b3a9ce118917e31b32a6488
+ source = tibia-starter.patch
+ sha256sums = 2fa3eee6ae78d37acc85f921816b4015be6b96ad0de08a4383084cf2ea5fdcd9
sha256sums = fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34
- sha256sums = 472f7516fe56b5a6270f0bda0069e59559cf6cbc0d9079a6607842a5ee1d1a7b
- depends_i686 = glu
- depends_i686 = mesa
- depends_x86_64 = lib32-glu
- depends_x86_64 = lib32-mesa
+ sha256sums = e91691e36a9f6228ece4f3346f21bce892f61902658d99c4a80e70daf0841325
pkgname = tibia
diff --git a/.gitignore b/.gitignore
index 4391da7c8914..276a1eab8937 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,4 @@ pkg/
src/
agreement.php
tibia*
-!tibia.sh
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index e5db7638e122..5848359f5430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
# Maintainer: Ricardo Cabral <ricardo.arturo.cabral@gmail.com>
-_name="Tibia"
+
pkgname=tibia
-pkgver=1096
-pkgrel=2
+pkgver=11.00.3839
+pkgrel=1
pkgdesc="A fast-paced free massively multiplayer online role-playing game."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.tibia.com"
license=('custom')
-depends_i686=('glu' 'mesa')
-depends_x86_64=('lib32-glu' 'lib32-mesa')
+depends=('glu' 'libgl' 'libice' 'libxext' 'pcre' 'qt5-base' 'qt5-declarative')
makedepends=('gendesk' 'python-html2text')
-source=("http://static.tibia.com/download/tibia${pkgver}.tgz"
- 'http://www.tibia.com/support/agreement.php'
- "tibia.sh")
+source=("${pkgname}-${pkgver}.tar.gz::http://static.tibia.com/download/tibia.x64.tar.gz"
+ 'http://www.tibia.com/support/agreement.php'
+ "tibia-starter.patch")
-sha256sums=('11bec465da38ae8e6d4d773c54142fa38b6f99207b3a9ce118917e31b32a6488'
+sha256sums=('2fa3eee6ae78d37acc85f921816b4015be6b96ad0de08a4383084cf2ea5fdcd9'
'fb192d96b893d012c0ecbf216885846c2826bdb72ae7824879959d3b01564f34'
- '472f7516fe56b5a6270f0bda0069e59559cf6cbc0d9079a6607842a5ee1d1a7b')
+ 'e91691e36a9f6228ece4f3346f21bce892f61902658d99c4a80e70daf0841325')
prepare() {
gendesk -f -n
html2text agreement.php > LICENSE
+
+ # Adjust start-tibia.sh
+ patch -Np1 -i "tibia-starter.patch"
}
package() {
mkdir -p "${pkgdir}/opt/Tibia"
- cp -drv --no-preserve=ownership ./Tibia/ "${pkgdir}/opt/"
+ cp -drv --no-preserve=ownership ${pkgname}-${pkgver}/* "${pkgdir}/opt/Tibia"
install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 Tibia/Tibia.xpm "${pkgdir}/usr/share/pixmaps/${pkgname}.xpm"
+ install -Dm644 ${pkgname}-${pkgver}/tibia.ico -t "${pkgdir}/usr/share/pixmaps/"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
mkdir -p "${pkgdir}/usr/bin"
- install -Dm755 tibia.sh "${pkgdir}/usr/bin/tibia"
+ install -Dm755 ${pkgname}-${pkgver}/start-tibia.sh "${pkgdir}/usr/bin/tibia"
}
diff --git a/tibia-starter.patch b/tibia-starter.patch
new file mode 100644
index 000000000000..d76506c92d85
--- /dev/null
+++ b/tibia-starter.patch
@@ -0,0 +1,12 @@
+--- a/tibia-11.00.3839/start-tibia.sh
++++ b/tibia-11.00.3839/start-tibia.sh
+@@ -3,8 +3,6 @@
+ # Adapts library load path to include Qt libraries found in the root folder of the client's binary file.
+ # client shouldn't be called directly to prevent needed libraries not being found.
+
+-SCRIPT=$(readlink -f "$0")
+-PATH=$(dirname "$SCRIPT")
+-BIN_PATH="$PATH/bin"
++BIN_PATH="/opt/Tibia/bin"
+
+ LD_LIBRARY_PATH="$BIN_PATH" exec "$BIN_PATH/client"
diff --git a/tibia.sh b/tibia.sh
deleted file mode 100755
index 0143bb9ae2f0..000000000000
--- a/tibia.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-cd "/opt/Tibia"
-./Tibia