aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile3
-rw-r--r--PKGBUILD2
-rw-r--r--README.md16
-rw-r--r--tick.113
5 files changed, 12 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce621b386e8e..c9c08ca75eeb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tick
pkgdesc = Command line stock and cryptocurrency portfolio tracker.
- pkgver = 1.9.0
+ pkgver = 1.10.0
pkgrel = 1
url = https://github.com/aokellermann/tick
arch = x86_64
diff --git a/Makefile b/Makefile
index f4001b0ddcdf..924c6176cff3 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,10 @@
CC = gcc
CFLAGS = -g -Wall --std=c99 -D_FORTIFY_SOURCE=2 -O2 \
--Wshadow -Wpointer-arith -pedantic \
+-Wshadow -Wpointer-arith -pedantic -Wold-style-definition \
-Wno-missing-braces -Wextra -Wno-missing-field-initializers -Wformat=2 \
-Wswitch-default -Wswitch-enum -Wcast-align -Wpointer-arith \
-Wbad-function-cast -Wstrict-overflow=5 -Wstrict-prototypes -Winline \
-Wundef -Wnested-externs -Wcast-qual -Wunreachable-code \
--Wold-style-definition \
-ggdb3 -fno-omit-frame-pointer -ffloat-store -fno-common -fstrict-aliasing
OBJECTS = main.o api.o portfolio.o rc4.o string-tick.o
LIBS = -lcurl -ljson-c -lm -lncurses
diff --git a/PKGBUILD b/PKGBUILD
index 624c1b7f7df0..4690d4a4a3c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Antony Kellermann <aokellermann@gmail.com>
pkgname=tick
-pkgver=1.9.0
+pkgver=1.10.0
pkgrel=1
pkgdesc="Command line stock and cryptocurrency portfolio tracker."
arch=('x86_64')
diff --git a/README.md b/README.md
index 8e936b51c93d..06fb30fb4105 100644
--- a/README.md
+++ b/README.md
@@ -70,12 +70,6 @@ $ tick news [symbol]
If you wish to use spaces in your input, you can either surround the phrase
with quotes or replace spaces with underscores.
-Note: As of version 1.7, the portfolio file has been reconstructed and formatted
-in JSON. To convert your existing portfolio, run
-```bash
-$ tick convert
-```
-
Once installed, you may read the man page for more information.
#### License
@@ -88,16 +82,14 @@ API. Shortened links are provided by Google's URL Shortener API. Please do
not abuse the APIs by repeatedly requesting information. Read the provided
license for more information.
#### Future Ideas/To-do
-* Historical support -- 7d/28d profits (wait for coinmarketcap release)
+* Historical support -- 7d/28d profits (wait for coinmarketcap historical release)
* Different ways to sort "check all"
* Look for API to replace Morningstar for MUTF/OTCMKTS data, preferably with
intraday data (wait for iex v2 probably)
* DEB/RPM package
* List whether stock/etf/mutual fund/crypto/etc. in portfolio for less API calls
and portfolio distribution (tried to implement, but IEX API is unpredictable; wait for v2)
-* Make printouts pretty with ncurses??
-* Check without re-encrypting in case sigint
-* Format prices with commas (set locale)
+* Make printouts pretty with ncurses (graph plots with historical prices?)
+* Format prices with commas (set locale?)
* Function to add new attributes to portfolio if not found
-* Improve code documentation
-* Round doubles \ No newline at end of file
+* Improve code documentation \ No newline at end of file
diff --git a/tick.1 b/tick.1
index 3388e7e3f88c..97610cac908c 100644
--- a/tick.1
+++ b/tick.1
@@ -1,4 +1,4 @@
-.TH TICK "1" "February 2018" "Tick 1.9.0" "User Commands"
+.TH TICK "1" "March 2018" "Tick 1.10.0" "User Commands"
.SH NAME
Tick - Command line stock and cryptocurrency portfolio tracker.
@@ -8,7 +8,7 @@ tick COMMAND [ARGUMENTS]
.SH DESCRIPTION
Create your portfolio by adding your current holdings. You can see information about your holdings with the command "check".
-You may also see information about securities that you may not own with commands "info"and "news".
+You may also see information about securities that you may not own with commands "info" and "news".
.SS
Portfolio:
@@ -32,11 +32,6 @@ will print information about all your current holdings, as well as a grand total
thing as 'tick check all'.
.TP
-[convert]
-If it exists, removes $HOME/.tick_portfolio.json and adds your current holding from the legacy portfolio, located at
-$HOME/.tick_portfolio.
-
-.TP
[encrypt/decrypt]
Encrypts or decrypts your portfolio using the RC4 algorithm. Password must be 32 characters or less.
@@ -96,7 +91,9 @@ Portfolio file.
Portfolio file (legacy).
.SH GITHUB
-Please report any bugs using the GitHub issue tracker: https://github.com/aokellermann/tick/issues
+Please report any bugs using the GitHub issue tracker:
+
+https://github.com/aokellermann/tick/issues
.SH AUTHORS
Antony Kellermann -- https://github.com/aokellermann