summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e229612c925..b2e2cb54ff53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 27 03:13:16 UTC 2018
+# Sat Apr 28 09:19:50 UTC 2018
pkgbase = tidb-bin
pkgdesc = A distributed NewSQL database compatible with MySQL protocol
- pkgver = 2.0.0.prega
+ pkgver = 2.0.0
pkgrel = 2
url = https://github.com/pingcap/tidb
arch = x86_64
@@ -11,10 +11,10 @@ pkgbase = tidb-bin
conflicts = tidb-bin-nightly
options = strip
options = debug
- source = https://download.pingcap.org/tidb-v2.0.0-prega-linux-amd64.tar.gz
+ source = https://download.pingcap.org/tidb-v2.0.0-linux-amd64.tar.gz
source = tidb.sysusers
source = tidb.tmpfiles
- sha256sums = 9fbe85deb73dbf46f8c2ba32502bd12344f6201b4f2cce235c823c1bdbd71002
+ sha256sums = 038bba8cd9f4552ddc42f913989eaafa2ce6844d5a6f7ad6d9752082242a3c28
sha256sums = 6fb6ae67a53c6cd054643542e76da6f16e000b029a98b34172972fcb505fc299
sha256sums = 15f285782938b3ebbb8be60cc962a2cbf5ca349527c39d3a1138be1bf976feb9
diff --git a/PKGBUILD b/PKGBUILD
index fc196458362c..67e58c403524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Jian Zeng <anonymousknight96@gmail.com>
pkgbase=tidb-bin
_basever=2.0.0
-_relver=prega
-pkgver=$_basever.$_relver
+#_relver=-prega
+#pkgver=$_basever.$_relver
+pkgver=$_basever
pkgrel=2
pkgname=("${pkgbase}" "${pkgbase}-utils")
pkgdesc="A distributed NewSQL database compatible with MySQL protocol"
@@ -14,11 +15,11 @@ license=('APACHE')
depends=('gcc-libs')
conflicts=('tidb-bin-nightly')
options=('strip' 'debug')
-source=("https://download.pingcap.org/tidb-v$_basever-$_relver-linux-amd64.tar.gz"
+source=("https://download.pingcap.org/tidb-v$_basever$_relver-linux-amd64.tar.gz"
"tidb.sysusers"
"tidb.tmpfiles"
)
-sha256sums=('9fbe85deb73dbf46f8c2ba32502bd12344f6201b4f2cce235c823c1bdbd71002'
+sha256sums=('038bba8cd9f4552ddc42f913989eaafa2ce6844d5a6f7ad6d9752082242a3c28'
'6fb6ae67a53c6cd054643542e76da6f16e000b029a98b34172972fcb505fc299'
'15f285782938b3ebbb8be60cc962a2cbf5ca349527c39d3a1138be1bf976feb9')
@@ -29,14 +30,14 @@ _package() {
install -Dm644 tidb.sysusers "$pkgdir"/usr/lib/sysusers.d/tidb.conf
install -Dm644 tidb.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/tidb.conf
- cd "tidb-v$_basever-$_relver-linux-amd64/bin"
+ cd "tidb-v$_basever$_relver-linux-amd64/bin"
install -dm755 "$pkgdir"/{etc/tidb,usr/bin}
install -Dm755 *-server "$pkgdir"/usr/bin
}
_package-utils() {
optdepends=('go-tools: provides goyacc')
- cd "tidb-v$_basever-$_relver-linux-amd64/bin"
+ cd "tidb-v$_basever$_relver-linux-amd64/bin"
install -dm755 "$pkgdir"/usr/bin
install -Dm755 *-ctl "$pkgdir"/usr/bin
install -Dm755 pd-recover "$pkgdir"/usr/bin