summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD72
-rw-r--r--vncserver.service29
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..199912b5d370
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = tightvnc
+ pkgdesc = VNC server and viewer
+ pkgver = 1.3.10
+ pkgrel = 10
+ url = http://www.tightvnc.com/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = imake
+ makedepends = setconf
+ makedepends = gendesk
+ depends = libjpeg
+ depends = zlib
+ depends = libxaw
+ depends = libxp
+ depends = xorg-xauth
+ depends = perl
+ options = !makeflags
+ source = http://downloads.sf.net/sourceforge/vnc-tight/tightvnc-1.3.10_unixsrc.tar.bz2
+ source = http://people.csail.mit.edu/jaffer/Color/rgb.txt
+ source = vncserver.service
+ source = tightvnc.png::http://www.tightvnc.com/logo/tightvnc-logo-90x90.png
+ sha256sums = f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d
+ sha256sums = af6c056a95ae725f98534db22b9a4916d17f2356fdca84a4a038211a82fa8a73
+ sha256sums = ccadf1fc708fad601e6113464d6c533a629f6dc9116f6071347cd0b465c1f48b
+ sha256sums = 9059bdfe62231fc645a35c3fe694c7e97e2bdeb5e3e23ce8eab2961e583219a8
+
+pkgname = tightvnc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a51c17056c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Paul Mattal <paul@archlinux.org>
+# Contributor: Andrew Hills <hills.as@gmail.com>
+# Contributor: John <graysky@archlinux.us>
+
+pkgname=tightvnc
+pkgver=1.3.10
+pkgrel=10
+pkgdesc='VNC server and viewer'
+arch=('x86_64' 'i686')
+license=('GPL')
+url='http://www.tightvnc.com/'
+depends=('libjpeg' 'zlib' 'libxaw' 'libxp' 'xorg-xauth' 'perl')
+makedepends=('imake' 'setconf' 'gendesk')
+options=('!makeflags')
+source=("http://downloads.sf.net/sourceforge/vnc-tight/$pkgname-${pkgver}_unixsrc.tar.bz2"
+ 'http://people.csail.mit.edu/jaffer/Color/rgb.txt'
+ 'vncserver.service'
+ 'tightvnc.png::http://www.tightvnc.com/logo/tightvnc-logo-90x90.png')
+sha256sums=('f48c70fea08d03744ae18df6b1499976362f16934eda3275cead87baad585c0d'
+ 'af6c056a95ae725f98534db22b9a4916d17f2356fdca84a4a038211a82fa8a73'
+ 'ccadf1fc708fad601e6113464d6c533a629f6dc9116f6071347cd0b465c1f48b'
+ '9059bdfe62231fc645a35c3fe694c7e97e2bdeb5e3e23ce8eab2961e583219a8')
+
+prepare() {
+ gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" --exec vncviewer \
+ --name 'TightVNC Viewer' --categories 'Application;Network'
+
+ cd vnc_unixsrc
+ setconf vncserver '$vncClasses' \"/usr/share/tightvnc\"\;
+ setconf vncserver '$fontPath' \
+ \"/usr/share/fonts/misc/,/usr/share/fonts/75dpi/,/usr/share/fonts/100dpi/,/usr/share/fonts/Type1/\"\;
+ sed -i 's:/lib/cpp:/usr/bin/cpp:' Xvnc/config/cf/linux.cf
+}
+
+build() {
+ cd vnc_unixsrc
+
+ xmkmf
+ make World
+
+ cd Xvnc
+ ./configure
+ setconf programs/Xserver/dix/Makefile DEFAULTRGBDATABASE '/usr/share/tightvnc/rgb'
+ setconf programs/Xserver/os/Makefile PROTO_DEFINES "-D_XOPEN_SOURCE=500L"
+ setconf lib/font/fc/Makefile PROTO_DEFINES "-D_XOPEN_SOURCE=500L"
+
+ make
+}
+
+package() {
+ cd vnc_unixsrc
+
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/man/man1"
+ install -d "$pkgdir/usr/share/$pkgname"
+
+ ./vncinstall "$pkgdir/usr/bin" "$pkgdir/usr/share/man"
+
+ cd "$srcdir"
+ install -Dm644 vnc_unixsrc/classes/* \
+ $pkgdir/usr/share/$pkgname
+ install -Dm644 rgb.txt $pkgdir/usr/share/$pkgname/rgb.txt
+ install -Dm644 $pkgname.desktop \
+ $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.png \
+ $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 vncserver.service \
+ $pkgdir/usr/lib/systemd/system/vncserver.service
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/vncserver.service b/vncserver.service
new file mode 100644
index 000000000000..b64e729a6c86
--- /dev/null
+++ b/vncserver.service
@@ -0,0 +1,29 @@
+# The vncserver service unit file
+#
+# 1. Copy this file to /etc/systemd/system/vncserver@:<display>.service
+# 2. Edit User=
+# ("User=foo")
+# 3. Edit and vncserver parameters appropriately
+# ("/usr/bin/vncserver %i -arg1 -arg2 -argn")
+# 4. Run `systemctl --system daemon-reload`
+# 5. Run `systemctl enable vncserver@:<display>.service`
+#
+# DO NOT RUN THIS SERVICE if your local area network is untrusted!
+#
+# See the wiki page for more on security
+# https://wiki.archlinux.org/index.php/Vncserver
+
+[Unit]
+Description=Remote desktop service (VNC)
+After=syslog.target network.target
+
+[Service]
+Type=forking
+User=
+# Clean any existing files in /tmp/.X11-unix environment, especially useful for VMs
+ExecStartPre=-/usr/bin/vncserver -kill %i
+ExecStart=/usr/bin/vncserver %i
+ExecStop=/usr/bin/vncserver -kill %i
+
+[Install]
+WantedBy=multi-user.target