summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rw-r--r--tilemaker.install8
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da887025ca64..a96998c2461a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = tilemaker
pkgdesc = Convert OpenStreetMap .pbf files into vector tiles without the stack
- pkgver = r14.6a994ee
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/systemed/tilemaker
+ install = tilemaker.install
arch = i686
arch = x86_64
license = custom
+ makedepends = boost
depends = boost-libs
- depends = luabind
+ depends = lua51
depends = protobuf
depends = sqlite
- source = tilemaker::git+https://github.com/systemed/tilemaker
- md5sums = SKIP
+ depends = shapelib
+ source = tilemaker-1.5.0.tar.gz::https://github.com/systemed/tilemaker/archive/v1.5.0.tar.gz
+ sha512sums = c826f8a0c1f9963ce48995c6ff4696b033fd3b582187ffaae6e46b8bdd2c7d6a157aea6df1ded69a294cccb1df6fd84824a5a749cbb55757ff0d6fdb3270f315
pkgname = tilemaker
diff --git a/PKGBUILD b/PKGBUILD
index ddd748cfbfdc..638aba4286d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Simon Legner <Simon.Legner@gmail.com>
pkgname=tilemaker
-pkgver=r14.6a994ee
-pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+pkgver=1.5.0
pkgrel=1
pkgdesc="Convert OpenStreetMap .pbf files into vector tiles without the stack"
arch=('i686' 'x86_64')
url="https://github.com/systemed/tilemaker"
license=('custom')
-depends=('boost-libs' 'luabind' 'protobuf' 'sqlite')
-source=("$pkgname::git+https://github.com/systemed/$pkgname")
-md5sums=('SKIP')
+install=$pkgname.install
+depends=('boost-libs' 'lua51' 'protobuf' 'sqlite' 'shapelib')
+makedepends=('boost')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/systemed/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('c826f8a0c1f9963ce48995c6ff4696b033fd3b582187ffaae6e46b8bdd2c7d6a157aea6df1ded69a294cccb1df6fd84824a5a749cbb55757ff0d6fdb3270f315')
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
make
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -Dm 0755 tilemaker $pkgdir/usr/bin/tilemaker
install -Dm 0644 LICENCE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/tilemaker.install b/tilemaker.install
new file mode 100644
index 000000000000..a1d8f38c62e5
--- /dev/null
+++ b/tilemaker.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo "See https://github.com/systemed/tilemaker/blob/master/CONFIGURATION.md for the configuration documentation"
+ echo "See https://github.com/systemed/tilemaker/blob/master/config.json for an example configuration"
+}
+
+post_upgrade() {
+ post_install
+}