summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
-rw-r--r--timecamp.install13
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..453bf92c1a0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Jul 30 23:29:20 UTC 2018
+pkgbase = timecamp
+ pkgdesc = Client application for TimeCamp software
+ pkgver = 1.4.3.3
+ pkgrel = 1
+ url = https://www.timecamp.com/
+ install = timecamp.install
+ arch = x86_64
+ license = custom
+ source = https://www.timecamp.com/downloadsoft/1.4.3.3/TimeCampSetup_LinAmd64-1.4.3.3.tar.gz
+ sha256sums = 51213dd2db59d8b4daa801682d5ec062d44341410a3fda4479d25b6dfc71264a
+
+pkgname = timecamp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..94cb21ba3bb3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/TimeCampSetup_*
+/timecamp-*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12f457e57406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Chris Hobbs (RX14) <chris@rx14.co.uk>
+pkgname=timecamp
+pkgver=1.4.3.3
+pkgrel=1
+pkgdesc="Client application for TimeCamp software"
+arch=('x86_64')
+url="https://www.timecamp.com/"
+license=('custom')
+depends=('gtk2' 'libsm' 'libnotify' 'libxss' 'libappindicator-gtk2')
+install=${pkgname}.install
+source=("https://www.timecamp.com/downloadsoft/${pkgver}/TimeCampSetup_LinAmd64-${pkgver}.tar.gz")
+sha256sums=("51213dd2db59d8b4daa801682d5ec062d44341410a3fda4479d25b6dfc71264a")
+
+package(){
+ # Extract package data
+ ar x timecamp.deb
+ tar xzf data.tar.gz -C "${pkgdir}"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /usr/share/timecamp/timecamp "${pkgdir}/usr/bin/timecamp"
+}
diff --git a/timecamp.install b/timecamp.install
new file mode 100644
index 000000000000..b50ffb36e4a2
--- /dev/null
+++ b/timecamp.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}