summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
-rw-r--r--timeshift-install.sh13
3 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 931eec6426d3..9f1217c43d31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Thu Jun 28 21:54:12 UTC 2018
+# Fri Aug 31 02:34:01 UTC 2018
pkgbase = timeshift
pkgdesc = A system restore utility for Linux
- pkgver = 18.6.1
+ pkgver = 18.8
pkgrel = 1
url = https://github.com/teejee2008/timeshift
+ install = timeshift-install.sh
arch = i686
arch = x86_64
license = GPL
@@ -18,11 +19,11 @@ pkgbase = timeshift
depends = rsync
depends = libgee>=0.18.0
depends = json-glib
- depends = cron
+ depends = cronie
optdepends = gksu: run timeshift from a menu
options = !emptydirs
- source = timeshift_v18.6.1.tgz::https://github.com/teejee2008/timeshift/archive/v18.6.1.tar.gz
- sha256sums = 2c851b232e622f75facc289a4a163218d1943b239eeadb2988acb23c80fc30a2
+ source = timeshift_v18.8.tgz::https://github.com/teejee2008/timeshift/archive/v18.8.tar.gz
+ sha256sums = a0fd832c0d65124d3d6f31c760f771473fa6ef2f62e6aad42e185ceaadf90eeb
pkgname = timeshift
diff --git a/PKGBUILD b/PKGBUILD
index d1547d8224ef..d76db516fe87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,8 @@ set -u
#_ubver='18.1'; _libgee='libgee>=0.18.0'
#_ubver='18.1.1'; _libgee='libgee>=0.18.0'
#_ubver='18.4'; _libgee='libgee>=0.18.0'
-_ubver='18.6.1'; _libgee='libgee>=0.18.0'
+#_ubver='18.6.1'; _libgee='libgee>=0.18.0'
+_ubver='18.8'; _libgee='libgee>=0.18.0'
pkgname='timeshift'
pkgver="${_ubver}"
pkgrel='1'
@@ -29,11 +30,12 @@ url='https://github.com/teejee2008/timeshift'
license=('GPL')
_arch_depends=('rsync' 'libgee06' 'json-glib') # from installer/install.sh
_arch_depends[1]="${_libgee}"
-depends=('gtk3' 'libsoup' 'desktop-file-utils' "${_arch_depends[@]}" 'cron')
+depends=('gtk3' 'libsoup' 'desktop-file-utils' "${_arch_depends[@]}" 'cronie')
unset _arch_depends
optdepends=('gksu: run timeshift from a menu')
makedepends=('vala' 'diffutils' 'coreutils' 'vte3')
options=('!emptydirs')
+install="${pkgname}-install.sh"
#_verwatch=("${url//code/bazaar}/trunk/changes" 'v\([0-9\.]\+\)' 't')
#source=("${url}/+files/${_srcdir}.tar.gz")
#_srcdir='~teejee2008/timeshift/trunk'
@@ -42,7 +44,7 @@ _github='teejee2008'
_verwatch=("https://github.com/${_github}/${pkgname}/releases.atom" '\s\+<title>Timeshift v\([0-9\.]\+\)</title>.*' 'f')
_srcdir="${pkgname}-${pkgver}"
source=("${pkgname}_v${pkgver}.tgz::https://github.com/${_github}/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('2c851b232e622f75facc289a4a163218d1943b239eeadb2988acb23c80fc30a2')
+sha256sums=('a0fd832c0d65124d3d6f31c760f771473fa6ef2f62e6aad42e185ceaadf90eeb')
#sha256sums[0]='SKIP'
build() {
diff --git a/timeshift-install.sh b/timeshift-install.sh
new file mode 100644
index 000000000000..bc3bd2167015
--- /dev/null
+++ b/timeshift-install.sh
@@ -0,0 +1,13 @@
+post_upgrade() {
+ set -u
+ if ! systemctl -q is-enabled 'cronie.service'; then
+ echo 'TimeShift automatic backups require the cronie.service to be running.'
+ echo 'Try:'
+ echo ' systemctl enable --now cronie.service'
+ fi
+ set +u
+}
+
+post_install() {
+ post_upgrade
+}