summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63ceabe6adfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tina
+ pkgdesc = tina is a personal information manager with a curses interface. It allows the user to categorize short text items and to display the items in a particular category.
+ pkgver = 0.1.12
+ pkgrel = 0
+ url = http://devel.ringlet.net/misc/tina/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://devel.ringlet.net/files/misc/tina/tina-0.1.12.tar.gz
+ md5sums = c0121de5f9c414b56512408879ba5d35
+
+pkgname = tina
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f56933aab990
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+tina-*.pkg.tar.xz
+tina-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd190857ef18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Juri Grabowski <gratuxri@gmail.com>
+
+pkgname=tina
+pkgver=0.1.12
+pkgrel=0
+pkgdesc="tina is a personal information manager with a curses interface. It allows the user to categorize short text items and to display the items in a particular category."
+arch=(any)
+url="http://devel.ringlet.net/misc/tina/"
+license=(GPL PerlArtistic)
+depends=(perl)
+options=('!emptydirs')
+_author="Peter Pentchev <roam@ringlet.net>"
+source=("http://devel.ringlet.net/files/misc/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('c0121de5f9c414b56512408879ba5d35')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}