summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 141eb68516f0..3b655d7c33ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,12 @@ sha512sums=(SKIP)
_pkgname=${pkgname%-irc-client-git}
+pkgver() {
+ cd $_pkgname
+ git describe --tags --long | \
+ sed -e 's/\([^-]*-\)g/r\1/' -e 's/-/./g' -e 's/^v//'
+}
+
build() {
cd $_pkgname
cargo install --path crates/$_pkgname --features=desktop-notifications