summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rwxr-xr-xbuild.sh3
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 484111944512..a4ec26b13d35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tinygo-bin
pkgdesc = TinyGo - Go for small spaces
- pkgver = 0.29.0
+ pkgver = 0.31.2
pkgrel = 1
url = https://tinygo.org
arch = x86_64
@@ -13,9 +13,9 @@ pkgbase = tinygo-bin
optdepends = arm-none-eabi-gdb: tinygo gdb support
provides = tinygo
conflicts = tinygo
- source = https://github.com/tinygo-org/tinygo/releases/download/v0.29.0/tinygo0.29.0.linux-amd64.tar.gz
- source = https://raw.githubusercontent.com/tinygo-org/tinygo/v0.29.0/LICENSE
- sha256sums = 46efb5d3181101f774f746120e4d0cc392b2216c3a960422f8f10cd62afdae05
+ source = https://github.com/tinygo-org/tinygo/releases/download/v0.31.2/tinygo0.31.2.linux-amd64.tar.gz
+ source = https://raw.githubusercontent.com/tinygo-org/tinygo/v0.31.2/LICENSE
+ sha256sums = 48a83ae9efe619124d2ecac8aba0b039ea8dabf07765b1df26692b63cfd8fab8
sha256sums = 122381213b7e2278825295b1d1469dd6fd4a22310cbbcb215192bde3f73b6950
pkgname = tinygo-bin
diff --git a/PKGBUILD b/PKGBUILD
index c411fec209a4..5383be0e5043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Johan Brandhorst <johan.brandhorst at gmail dot com>
pkgname=tinygo-bin
-pkgver=0.29.0
+pkgver=0.31.2
pkgrel=1
epoch=
pkgdesc='TinyGo - Go for small spaces'
@@ -20,7 +20,7 @@ conflicts=('tinygo')
source=("https://github.com/tinygo-org/tinygo/releases/download/v${pkgver}/tinygo${pkgver}.linux-amd64.tar.gz"
"https://raw.githubusercontent.com/tinygo-org/tinygo/v${pkgver}/LICENSE"
)
-sha256sums=('46efb5d3181101f774f746120e4d0cc392b2216c3a960422f8f10cd62afdae05'
+sha256sums=('48a83ae9efe619124d2ecac8aba0b039ea8dabf07765b1df26692b63cfd8fab8'
'122381213b7e2278825295b1d1469dd6fd4a22310cbbcb215192bde3f73b6950')
package() {
diff --git a/build.sh b/build.sh
index ffc972be6e32..07b2a77c2be7 100755
--- a/build.sh
+++ b/build.sh
@@ -7,7 +7,8 @@ docker run \
--entrypoint /usr/bin/bash \
--workdir /srv \
docker.io/archlinux:latest -c '\
- pacman -Syu --noconfirm pacman-contrib pacman git sudo binutils go && \
+ pacman -Sy --noconfirm --needed archlinux-keyring && \
+ pacman -Syu --noconfirm pacman-contrib pacman git sudo binutils go debugedit && \
git config --global --add safe.directory /srv && \
git clean -fdx && \
chmod a+w PKGBUILD .SRCINFO . && \