summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD29
-rw-r--r--tinyos.profile4
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ff998076a31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = tinyos
+ pkgdesc = Small operating system for sensor motes, embedded devices
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = http://www.tinyos.net/
+ arch = any
+ license = GPL
+ depends = glibc
+ depends = nesc
+ optdepends = jdk: for building java tools for tinyos applications
+ optdepends = jre: for using java tools
+ optdepends = avr-libc-tinyos: to build for atmel based platforms
+ optdepends = avrdude: to installing for atmel based platform (which is not supported by uisp, like iris)
+ optdepends = binutils-msp430: to build for msp430 based platforms
+ optdepends = gcc-msp430: to build for msp430 based platforms
+ optdepends = msp430-libc: to build for msp430 based platforms
+ options = !libtool
+ source = http://tinyos.stanford.edu/tinyos/dists/source/tinyos-2.1.2.tar.gz
+ source = tinyos.profile
+ md5sums = 58c894214a353866a4a11774c3372dae
+ md5sums = 242f5d337860fd4f5c713bf39a5e5c1d
+
+pkgname = tinyos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8e9bb7cabdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ABDULLATIF Mouhamadi <bourou01dev@gmail.com>
+pkgname=tinyos
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="Small operating system for sensor motes, embedded devices"
+arch=(any)
+license=(GPL)
+options=(!libtool)
+url="http://www.tinyos.net/"
+depends=('glibc' 'nesc')
+optdepends=('jdk: for building java tools for tinyos applications'
+ 'jre: for using java tools'
+ 'avr-libc-tinyos: to build for atmel based platforms'
+ 'avrdude: to installing for atmel based platform (which is not supported by uisp, like iris)'
+ 'binutils-msp430: to build for msp430 based platforms'
+ 'gcc-msp430: to build for msp430 based platforms'
+ 'msp430-libc: to build for msp430 based platforms')
+
+source=(http://tinyos.stanford.edu/tinyos/dists/source/${pkgname}-${pkgver}.tar.gz
+ tinyos.profile)
+md5sums=('58c894214a353866a4a11774c3372dae'
+ '242f5d337860fd4f5c713bf39a5e5c1d')
+
+package() {
+
+ install -d ${pkgdir}/opt
+ cp -aR ${srcdir}/${pkgname}-${pkgver}/ ${pkgdir}/opt
+ install -D -m755 ${srcdir}/${pkgname}.profile ${pkgdir}/etc/profile.d/${pkgname}.sh
+}
diff --git a/tinyos.profile b/tinyos.profile
new file mode 100644
index 000000000000..67dc48fcf708
--- /dev/null
+++ b/tinyos.profile
@@ -0,0 +1,4 @@
+export TOSROOT=/opt/tinyos-2.1.2
+export TOSDIR=$TOSROOT/tos
+export CLASSPATH=$CLASSPATH:$TOSROOT/support/sdk/java/tinyos.jar
+export MAKERULES=$TOSROOT/support/make/Makerules