summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-man-path.patch28
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD88
-rw-r--r--tlp-arch.patch41
5 files changed, 55 insertions, 120 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6dd7b5aa4e96..a33917826dba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
# Generated by mksrcinfo v8
-# Tue Jan 19 10:08:23 UTC 2016
+# Wed Apr 17 11:55:03 UTC 2019
pkgbase = tlp-git
- pkgver = 0.8.r51.f54b606
+ pkgver = 1.2.1.r22.5d2abde
pkgrel = 1
- url = http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html
+ url = https://linrunner.de/en/tlp/tlp.html
arch = any
license = GPL2
- license = GPL3
makedepends = git
- source = tlp::git+https://github.com/linrunner/TLP.git
+ source = git+https://github.com/linrunner/TLP.git
sha256sums = SKIP
pkgname = tlp-git
@@ -19,11 +18,10 @@ pkgname = tlp-git
depends = rfkill
depends = usbutils
depends = util-linux
- optdepends = acpi_call: Sandy Bridge and newer ThinkPad battery functions
+ optdepends = bash-completion: Bash completion
optdepends = ethtool: Disable Wake On Lan
optdepends = lsb-release: Display LSB release version in tlp-stat
optdepends = smartmontools: Display S.M.A.R.T. data in tlp-stat
- optdepends = tp_smapi: ThinkPad battery functions
optdepends = x86_energy_perf_policy: Set energy versus performance policy on x86 processors
provides = tlp
conflicts = laptop-mode-tools
diff --git a/0001-Fix-man-path.patch b/0001-Fix-man-path.patch
deleted file mode 100644
index 341a13b31c9f..000000000000
--- a/0001-Fix-man-path.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From e3ffad2c3555efc9883c89f67d141cc4a3f151ed Mon Sep 17 00:00:00 2001
-From: Maxime Gauduin <alucryd@archlinux.org>
-Date: Sun, 3 Jan 2016 15:33:36 +0100
-Subject: [PATCH] Fix man path
-
----
- Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index f79b254..1f39158 100644
---- a/Makefile
-+++ b/Makefile
-@@ -100,9 +100,9 @@ install-rdw: all
- install-man:
- # manpages
- install -d -m 755 $(_MAN)/man1
-- install -m 644 {bluetooth,run-on-ac,run-on-bat,wifi,wwan}.1 $(_MAN)/man1/
-+ install -m 644 man/{bluetooth,run-on-ac,run-on-bat,wifi,wwan}.1 $(_MAN)/man1/
- install -d -m 755 $(_MAN)/man8
-- install -m 644 {tlp,tlp-stat}.8 $(_MAN)/man8/
-+ install -m 644 man/{tlp,tlp-stat}.8 $(_MAN)/man8/
-
- install: install-tlp install-rdw
-
---
-2.6.4
-
diff --git a/MKPKG b/MKPKG
deleted file mode 100644
index 60c4d2f12563..000000000000
--- a/MKPKG
+++ /dev/null
@@ -1,6 +0,0 @@
-arch=('any')
-pkgname=('tlp-git' 'tlp-rdw-git')
-
-check_git $packagedir/tlp-git/tlp
-
-# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
index 5a81c2ee34ef..462e4933acf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,70 @@
# Contributor: Marc Schulte <bomba@nerdstube.de>
pkgbase=tlp-git
-pkgname=('tlp-git' 'tlp-rdw-git')
-pkgver=0.8.r51.f54b606
+pkgname=(
+ tlp-git
+ tlp-rdw-git
+)
+pkgver=1.2.1.r22.5d2abde
pkgrel=1
-arch=('any')
-url='http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html'
-license=('GPL2' 'GPL3')
-makedepends=('git')
-source=('tlp::git+https://github.com/linrunner/TLP.git')
-sha256sums=('SKIP')
+arch=(any)
+url=https://linrunner.de/en/tlp/tlp.html
+license=(GPL2)
+makedepends=(git)
+source=(git+https://github.com/linrunner/TLP.git)
+sha256sums=(SKIP)
pkgver() {
- cd tlp
-
- tag='0.8'
+ cd TLP
echo "$(git describe --tags | sed 's/-/.r/; s/-g/./')"
}
package_tlp-git() {
pkgdesc='Linux Advanced Power Management'
- depends=('hdparm' 'iw' 'pciutils' 'rfkill' 'usbutils' 'util-linux')
- optdepends=('acpi_call: Sandy Bridge and newer ThinkPad battery functions'
- 'ethtool: Disable Wake On Lan'
- 'lsb-release: Display LSB release version in tlp-stat'
- 'smartmontools: Display S.M.A.R.T. data in tlp-stat'
- 'tp_smapi: ThinkPad battery functions'
- 'x86_energy_perf_policy: Set energy versus performance policy on x86 processors')
- provides=('tlp')
- conflicts=('laptop-mode-tools' 'pm-utils' 'tlp')
- backup=('etc/default/tlp')
-
- cd tlp
-
- export TLP_SBIN='/usr/bin'
- export TLP_ULIB='/usr/lib/udev'
- export TLP_SYSD='/usr/lib/systemd/system'
- export TLP_NO_INIT='1'
- export TLP_NO_PMUTILS='1'
- export TLP_WITH_SYSTEMD='1'
-
- make DESTDIR="${pkgdir}" install-tlp install-man
+ depends=(
+ hdparm
+ iw
+ pciutils
+ rfkill
+ usbutils
+ util-linux
+ )
+ optdepends=(
+ 'bash-completion: Bash completion'
+ 'ethtool: Disable Wake On Lan'
+ 'lsb-release: Display LSB release version in tlp-stat'
+ 'smartmontools: Display S.M.A.R.T. data in tlp-stat'
+ 'x86_energy_perf_policy: Set energy versus performance policy on x86 processors'
+ )
+ provides=(tlp)
+ conflicts=(
+ laptop-mode-tools
+ pm-utils
+ tlp
+ )
+ backup=(etc/default/tlp)
+
+ export TLP_SBIN=/usr/bin
+ export TLP_ULIB=/usr/lib/udev
+ export TLP_SYSD=/usr/lib/systemd/system
+ export TLP_NO_INIT=1
+ export TLP_WITH_SYSTEMD=1
+ export TLP_WITH_ELOGIND=0
+
+ make DESTDIR="${pkgdir}" -C TLP install-tlp install-man
}
package_tlp-rdw-git() {
pkgdesc='Linux Advanced Power Management - Radio Device Wizard'
- depends=('networkmanager' 'tlp')
- provides=('tlp-rdw')
- conflicts=('tlp-rdw')
-
- cd tlp
+ depends=(
+ networkmanager
+ tlp
+ )
+ provides=(tlp-rdw)
+ conflicts=(tlp-rdw)
- make DESTDIR="${pkgdir}" install-rdw
+ make DESTDIR="${pkgdir}" -C TLP install-rdw install-man-rdw
}
# vim: ts=2 sw=2 et:
diff --git a/tlp-arch.patch b/tlp-arch.patch
deleted file mode 100644
index fbf3c6b31a3d..000000000000
--- a/tlp-arch.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -rupN tlp.orig/tlp.rules tlp/tlp.rules
---- tlp.orig/tlp.rules 2015-01-10 02:43:33.341388989 +0100
-+++ tlp/tlp.rules 2015-01-10 02:45:33.361390081 +0100
-@@ -4,7 +4,7 @@
- # This software is licensed under the GPL v2 or later.
-
- # handle change of power source ac/bat
--ACTION=="change", SUBSYSTEM=="power_supply", ATTR{type}=="Mains", RUN+="/usr/sbin/tlp auto"
-+ACTION=="change", SUBSYSTEM=="power_supply", ATTR{type}=="Mains", RUN+="/usr/bin/tlp auto"
-
- # handle added usb devices (exclude subdevices via DRIVER=="USB")
--ACTION=="add", SUBSYSTEM=="usb", DRIVER=="usb", ENV{DEVTYPE}=="usb_device", RUN+="/lib/udev/tlp-usb-udev %p"
-+ACTION=="add", SUBSYSTEM=="usb", DRIVER=="usb", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/udev/tlp-usb-udev %p"
-diff -rupN tlp.orig/tlp.service tlp/tlp.service
---- tlp.orig/tlp.service 2015-01-10 02:43:33.341388989 +0100
-+++ tlp/tlp.service 2015-01-10 02:43:48.678055785 +0100
-@@ -11,8 +11,8 @@ Before=shutdown.target
- [Service]
- Type=simple
- RemainAfterExit=yes
--ExecStart=/usr/sbin/tlp init start
--ExecStop=/usr/sbin/tlp init stop
-+ExecStart=/usr/bin/tlp init start
-+ExecStop=/usr/bin/tlp init stop
-
- [Install]
- WantedBy=multi-user.target
-diff -rupN tlp.orig/tlp-sleep.service tlp/tlp-sleep.service
---- tlp.orig/tlp-sleep.service 2015-01-10 02:43:33.341388989 +0100
-+++ tlp/tlp-sleep.service 2015-01-10 02:43:48.678055785 +0100
-@@ -11,8 +11,8 @@ StopWhenUnneeded=yes
- [Service]
- Type=oneshot
- RemainAfterExit=yes
--ExecStart=/usr/sbin/tlp suspend
--ExecStop=/usr/sbin/tlp resume
-+ExecStart=/usr/bin/tlp suspend
-+ExecStop=/usr/bin/tlp resume
-
- [Install]
- WantedBy=sleep.target