summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-man-path.patch28
-rw-r--r--PKGBUILD18
3 files changed, 41 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 532dcf6ce0f2..68b336cc1368 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Jan 3 14:38:33 UTC 2016
pkgbase = tlp-git
- pkgver = 0.8.r0.6f7bca9
+ pkgver = 0.8.r34.788c4df
pkgrel = 1
url = http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html
arch = any
license = GPL2
license = GPL3
makedepends = git
- source = tlp::git+https://github.com/linrunner/TLP.git#branch=devel
- source = tlp-arch.patch
+ source = tlp::git+https://github.com/linrunner/TLP.git
+ source = 0001-Fix-man-path.patch
sha256sums = SKIP
- sha256sums = 836a07ebb222d7d696ac33d8596a9b129debb70793bb4dbb6283ce8311ea303c
+ sha256sums = f5a6e1d417fff03ca37a12e6203c2a53d0b266ceedc5ad21e51e57e686d601bf
pkgname = tlp-git
pkgdesc = Linux Advanced Power Management
diff --git a/0001-Fix-man-path.patch b/0001-Fix-man-path.patch
new file mode 100644
index 000000000000..341a13b31c9f
--- /dev/null
+++ b/0001-Fix-man-path.patch
@@ -0,0 +1,28 @@
+From e3ffad2c3555efc9883c89f67d141cc4a3f151ed Mon Sep 17 00:00:00 2001
+From: Maxime Gauduin <alucryd@archlinux.org>
+Date: Sun, 3 Jan 2016 15:33:36 +0100
+Subject: [PATCH] Fix man path
+
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index f79b254..1f39158 100644
+--- a/Makefile
++++ b/Makefile
+@@ -100,9 +100,9 @@ install-rdw: all
+ install-man:
+ # manpages
+ install -d -m 755 $(_MAN)/man1
+- install -m 644 {bluetooth,run-on-ac,run-on-bat,wifi,wwan}.1 $(_MAN)/man1/
++ install -m 644 man/{bluetooth,run-on-ac,run-on-bat,wifi,wwan}.1 $(_MAN)/man1/
+ install -d -m 755 $(_MAN)/man8
+- install -m 644 {tlp,tlp-stat}.8 $(_MAN)/man8/
++ install -m 644 man/{tlp,tlp-stat}.8 $(_MAN)/man8/
+
+ install: install-tlp install-rdw
+
+--
+2.6.4
+
diff --git a/PKGBUILD b/PKGBUILD
index ce82839e77fd..309fb69353ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@
pkgbase=tlp-git
pkgname=('tlp-git' 'tlp-rdw-git')
-pkgver=0.8.r0.6f7bca9
+pkgver=0.8.r34.788c4df
pkgrel=1
arch=('any')
url='http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html'
license=('GPL2' 'GPL3')
makedepends=('git')
-source=('tlp::git+https://github.com/linrunner/TLP.git#branch=devel'
- 'tlp-arch.patch')
+source=('tlp::git+https://github.com/linrunner/TLP.git'
+ '0001-Fix-man-path.patch')
sha256sums=('SKIP'
- '836a07ebb222d7d696ac33d8596a9b129debb70793bb4dbb6283ce8311ea303c')
+ 'f5a6e1d417fff03ca37a12e6203c2a53d0b266ceedc5ad21e51e57e686d601bf')
pkgver() {
cd tlp
tag='0.8'
- echo "${tag}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
+ echo "$(git describe --tags | sed 's/-/.r/; s/-g/./')"
}
prepare() {
cd tlp
- patch -Np1 -i ../tlp-arch.patch
+ patch -Np1 -i ../0001-Fix-man-path.patch
}
package_tlp-git() {
@@ -50,11 +50,7 @@ package_tlp-git() {
export TLP_NO_PMUTILS='1'
export TLP_WITH_SYSTEMD='1'
- make DESTDIR="${pkgdir}" install-tlp
-
- install -dm 755 "${pkgdir}"/usr/share/man/man{1,8}
- install -m 644 man/*.1 "${pkgdir}"/usr/share/man/man1/
- install -m 644 man/*.8 "${pkgdir}"/usr/share/man/man8/
+ make DESTDIR="${pkgdir}" install-tlp install-man
}
package_tlp-rdw-git() {