summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--tmpwatch.install11
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0b36e818be8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmpwatch
+ pkgdesc = Removes files which haven't been accessed for a period of time
+ pkgver = 2.11
+ pkgrel = 2
+ url = http://fedorahosted.org/tmpwatch/
+ install = tmpwatch.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = https://fedorahosted.org/releases/t/m/tmpwatch/tmpwatch-2.11.tar.bz2
+ sha256sums = 93168112b2515bc4c7117e8113b8d91e06b79550d2194d62a0c174fe6c2aa8d4
+
+pkgname = tmpwatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..971aae6ef5f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Simon Perry <pezz at sanxion dot net>
+# Contributor: Daniele Paolella <dp@hostess-promoter.com>
+pkgname=tmpwatch
+pkgver=2.11
+pkgrel=2
+pkgdesc="Removes files which haven't been accessed for a period of time"
+arch=('i686' 'x86_64')
+url="http://fedorahosted.org/tmpwatch/"
+license=('GPL2')
+depends=('glibc')
+install=${pkgname}.install
+source=("https://fedorahosted.org/releases/t/m/tmpwatch/tmpwatch-$pkgver.tar.bz2")
+sha256sums=('93168112b2515bc4c7117e8113b8d91e06b79550d2194d62a0c174fe6c2aa8d4')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/tmpwatch.install b/tmpwatch.install
new file mode 100644
index 000000000000..234a547f0dfd
--- /dev/null
+++ b/tmpwatch.install
@@ -0,0 +1,11 @@
+
+post_upgrade() {
+ cat << _EOF
+
+* IMPORTANT: Location of the tmpwatch binary has changed
+* from /usr/sbin to /usr/bin -- be sure to update any
+* scripts or cron jobs.
+
+_EOF
+}
+