summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e3a25c84ea2..8c89b52c9b4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tmux-bash-completion-git
pkgdesc = Bash completion for tmux
pkgver = r16.f5d5323
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/imomaliev/tmux-bash-completion
arch = any
license = GPL2
@@ -10,7 +10,7 @@ pkgbase = tmux-bash-completion-git
depends = tmux
provides = tmux-bash-completion
conflicts = tmux-bash-completion
- source = git+https://github.com/imomaliev/tmux-bash-completion
- md5sums = SKIP
+ source = git+https://github.com/imomaliev/tmux-bash-completion.git
+ sha256sums = SKIP
pkgname = tmux-bash-completion-git
diff --git a/PKGBUILD b/PKGBUILD
index 49d463d54347..0d2461b903de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=tmux-bash-completion-git
pkgver=r16.f5d5323
-pkgrel=1
+pkgrel=2
pkgdesc="Bash completion for tmux"
arch=('any')
url="https://github.com/imomaliev/tmux-bash-completion"
@@ -13,8 +13,8 @@ depends=('bash-completion' 'tmux')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url")
-md5sums=('SKIP')
+source=("git+$url.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -22,8 +22,6 @@ pkgver() {
}
package() {
- cd "${pkgname%-git}/completions"
- for file in * ; do
- install -Dm644 "$file" "$pkgdir/usr/share/bash-completion/completions/$file"
- done
+ cd "${pkgname%-git}"
+ install -Dm644 -t "$pkgdir/usr/share/bash-completion/completions/" completions/*
}