summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 25 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebe347f1963c..d93e28883f3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by makepkg 5.0.1
-# Wed Aug 17 16:24:21 UTC 2016
+# Generated by makepkg 6.0.2
+# Mon Dec 19 13:44:22 UTC 2022
pkgbase = tntnet
pkgdesc = Modular, multithreaded, high performance webapplicationserver for C++
- pkgver = 2.2.1
- pkgrel = 2
+ pkgver = 3.0
+ pkgrel = 3
url = http://www.tntnet.org
arch = x86_64
arch = i686
@@ -14,8 +14,10 @@ pkgbase = tntnet
depends = cxxtools
depends = openssl
depends = zlib
- source = http://www.tntnet.org/download/tntnet-2.2.1.tar.gz
- md5sums = febe799675c1b8b2f7259bad30cf6f23
+ depends = perl
+ source = tntnet-3.0_git.tar.gz::https://github.com/maekitalo/tntnet/archive/refs/tags/V3.0.tar.gz
+ source = tntnet-autoconf-2.70-fixes.patch::https://github.com/maekitalo/tntnet/commit/69adfc8ee351a0e82990c1ffa7af6dab726e1e49.patch
+ sha256sums = bc16249f7af7c7b407ec37bb397fe1eb8b54d2410dd5208531ca58908fc19f48
+ sha256sums = 401573b47d74348d065a9a83af0428525bcb90d88142e02c0d647ec10bb3f9df
pkgname = tntnet
-
diff --git a/PKGBUILD b/PKGBUILD
index 1a9214aed1e1..b1aad3ffe5fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,31 @@
# Maintainer: Christopher Reimer <mail+vdr4arch[at]c-reimer[dot]de>
pkgname=tntnet
-pkgver=2.2.1
-pkgrel=2
+pkgver=3.0
+pkgrel=3
pkgdesc="Modular, multithreaded, high performance webapplicationserver for C++"
url="http://www.tntnet.org"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
license=('GPL2')
-depends=('cxxtools' 'openssl' 'zlib')
-source=("http://www.tntnet.org/download/${pkgname}-${pkgver}.tar.gz")
-md5sums=('febe799675c1b8b2f7259bad30cf6f23')
+depends=('cxxtools' 'openssl' 'zlib' 'perl')
+source=("$pkgname-${pkgver}_git.tar.gz::https://github.com/maekitalo/tntnet/archive/refs/tags/V${pkgver}.tar.gz"
+ "$pkgname-autoconf-2.70-fixes.patch::https://github.com/maekitalo/tntnet/commit/69adfc8ee351a0e82990c1ffa7af6dab726e1e49.patch")
+sha256sums=('bc16249f7af7c7b407ec37bb397fe1eb8b54d2410dd5208531ca58908fc19f48'
+ '401573b47d74348d065a9a83af0428525bcb90d88142e02c0d647ec10bb3f9df')
+
+prepare() {
+ # autoconf-2.70 fixes
+ patch -d "$pkgname-$pkgver" -p1 -i "../$pkgname-autoconf-2.70-fixes.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -i
./configure --prefix=/usr \
- --disable-static \
+ --sysconfdir=/etc \
--disable-unittest \
- --with-demos=no \
- --with-server=no
+ --without-demos \
+ --without-server
make
}