summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD27
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ba84dd7dfa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Mon Oct 24 12:22:16 UTC 2016
+pkgbase = toad
+ pkgdesc = Toad: Trainer Of All Data, the Frog training collection
+ pkgver = 1
+ pkgrel = 1
+ url = http://github.com/languagemachines/toad/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = libtool
+ makedepends = autoconf
+ depends = ticcutils
+ depends = ucto
+ depends = libfolia
+ depends = icu
+ depends = libxml2
+ depends = timbl
+ depends = mbt
+ depends = frog
+ depends = frogdata
+ options = !libtool
+ source = https://github.com/LanguageMachines/toad/archive/v0.3.1.tar.gz
+ md5sums = SKIP
+
+pkgname = toad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c78cafbd9be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Maarten van Gompel <proycon at anaproy.nl>
+pkgname=toad
+pkgver=1
+pkgrel=1
+pkgdesc="Toad: Trainer Of All Data, the Frog training collection"
+arch=('i686' 'x86_64')
+url="http://github.com/languagemachines/toad/"
+license=('GPL3')
+depends=('ticcutils' 'ucto' 'libfolia' 'icu' 'libxml2' 'timbl' 'mbt' 'frog' 'frogdata')
+makedepends=('libtool' 'autoconf')
+options=(!libtool)
+source=(https://github.com/LanguageMachines/toad/archive/v0.3.1.tar.gz)
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ bash bootstrap.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
+
+