summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d3284544bc0..afda5fe4fca3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = todoist-full-offline-backup
pkgdesc = Small, dependency-less Python script to make a backup of all Todoist tasks and attachments that is accessible offline
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/joanbm/full-offline-backup-for-todoist
arch = any
license = GPLv3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
source = full-offline-backup-for-todoist-0.5.0.tar.gz::https://github.com/joanbm/full-offline-backup-for-todoist/archive/0.5.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3c61f125b1ae..45ab60519be9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname=full-offline-backup-for-todoist
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Small, dependency-less Python script to make a backup of all Todoist tasks and attachments that is accessible offline"
arch=('any')
url="https://github.com/joanbm/full-offline-backup-for-todoist"
license=('GPLv3')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/joanbm/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('bf40d32d26d785b424a08a15e415987cc44547032c396338d4f19a66060eaba0')
+build() {
+ cd "${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
check() {
cd "${pkgname}-${pkgver}"
python -m unittest
@@ -18,5 +23,5 @@ check() {
package() {
cd "${pkgname}-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}